dev-tex/translator: bump EAPI and stuff
authorAaron Bauman <bman@gentoo.org>
Sat, 9 Nov 2019 21:56:27 +0000 (16:56 -0500)
committerAaron Bauman <bman@gentoo.org>
Sat, 9 Nov 2019 22:12:37 +0000 (17:12 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-tex/translator/translator-1.00.ebuild

index b90846db4d178fdb202a55df8199bde84717e34a..d0d6945f4b4c9a7e9dc42c1ee969000ab66cf11c 100644 (file)
@@ -1,28 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit latex-package
 
 DESCRIPTION="A package for translating words in TeX"
-HOMEPAGE="http://latex-beamer.sourceforge.net/"
+HOMEPAGE="https://bitbucket.org/rivanvx/beamer/src"
 SRC_URI="mirror://sourceforge/latex-beamer/${P}.tar.gz"
 
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
+
 LICENSE="GPL-2 LPPL-1.3c"
 SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
 IUSE="doc"
 
 TEXMF="/usr/share/texmf-site"
 
 src_install() {
-       insinto ${TEXMF}/tex/latex/${PN}
-       doins base/* || die "Failed to install the package"
-       doins -r dicts/* || die "Failed to install dictonaries"
-       dodoc ChangeLog README || die "dodoc failed"
-       if use doc ; then
-               insinto /usr/share/doc/${PF}
-               doins -r doc/* || die "Failed to install documentation"
-       fi
+       insinto ${TEXMF}/tex/latex/translator
+       doins base/*
+       doins -r dicts/*
+       dodoc ChangeLog README
+
+       use doc && dodoc -r doc/*
 }