Temporary fix for plugins getting installed in /usr/local
authorJoshua Nichols <nichoj@gentoo.org>
Sat, 9 Dec 2006 00:32:31 +0000 (00:32 +0000)
committerJoshua Nichols <nichoj@gentoo.org>
Sat, 9 Dec 2006 00:32:31 +0000 (00:32 +0000)
Package-Manager: portage-2.1.2_rc2-r1

xfce-base/xfce-mcs-plugins/ChangeLog
xfce-base/xfce-mcs-plugins/files/digest-xfce-mcs-plugins-4.3.99.2-r2 [new file with mode: 0644]
xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.3.99.2-r2.ebuild [new file with mode: 0644]

index b112d42c783e0ba823a381c5651d25cf8010dd82..e18cb17c024d1820e52556527c649fd8db78cd00 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for xfce-base/xfce-mcs-plugins
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-mcs-plugins/ChangeLog,v 1.70 2006/12/08 21:55:36 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-mcs-plugins/ChangeLog,v 1.71 2006/12/09 00:32:30 nichoj Exp $
+
+*xfce-mcs-plugins-4.3.99.2-r2 (09 Dec 2006)
+
+  09 Dec 2006; Joshua Nichols <nichoj@gentoo.org>
+  -xfce-mcs-plugins-4.3.99.2-r1.ebuild,
+  +xfce-mcs-plugins-4.3.99.2-r2.ebuild:
+  Temporary fix for plugins getting installed in /usr/local
 
 *xfce-mcs-plugins-4.3.99.2-r1 (08 Dec 2006)
 
diff --git a/xfce-base/xfce-mcs-plugins/files/digest-xfce-mcs-plugins-4.3.99.2-r2 b/xfce-base/xfce-mcs-plugins/files/digest-xfce-mcs-plugins-4.3.99.2-r2
new file mode 100644 (file)
index 0000000..4d8505d
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 6234425227e1145319bd75ef52fa97f5 xfce-mcs-plugins-4.3.99.2.tar.bz2 842712
+RMD160 572088b0429f984bedc62484a7a28b2d37aab305 xfce-mcs-plugins-4.3.99.2.tar.bz2 842712
+SHA256 f2773a4c007139f0a06c418b3535374ebeed8e10eef41d3ae69f4259f6f632a5 xfce-mcs-plugins-4.3.99.2.tar.bz2 842712
diff --git a/xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.3.99.2-r2.ebuild b/xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.3.99.2-r2.ebuild
new file mode 100644 (file)
index 0000000..ce9a0b2
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.3.99.2-r2.ebuild,v 1.1 2006/12/09 00:32:30 nichoj Exp $
+
+inherit gnome2 xfce44
+
+xfce44_beta
+
+DESCRIPTION="Xfce4 mcs plugins"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="|| ( ( x11-libs/libX11
+       x11-libs/libXcursor
+       x11-libs/libXrandr
+       x11-libs/libXrender
+       x11-libs/libICE
+       x11-libs/libSM
+       x11-libs/libXext
+       x11-libs/libXxf86misc
+       x11-libs/libXxf86vm )
+       virtual/x11 )
+       >=dev-libs/glib-2
+       >=x11-libs/gtk+-2.6
+       ~xfce-base/libxfce4mcs-${PV}
+       ~xfce-base/libxfce4util-${PV}
+       ~xfce-base/libxfcegui4-${PV}
+       ~xfce-base/xfce-mcs-manager-${PV}"
+# need xfce4-dev-tools, since we patch automake and need regeneration
+DEPEND="${RDEPEND}
+       || ( ( x11-proto/xf86miscproto
+       x11-proto/xf86vidmodeproto
+       x11-proto/xproto )
+       virtual/x11 )
+       xfce-extra/xfce4-dev-tools"
+
+CONFIGURE="xdt-autogen"
+XFCE_CONFIG="--enable-xf86misc --enable-xkb --enable-randr --enable-xf86vm
+--prefix=/usr"
+
+xfce44_core_package
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+       epatch ${FILESDIR}/${P}-icon.patch
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}