Version bump. Fixed bug #150558 (thanks to Fabrice Delliaux) and depend now on >...
authorTiziano Müller <dev-zero@gentoo.org>
Fri, 29 Dec 2006 23:18:50 +0000 (23:18 +0000)
committerTiziano Müller <dev-zero@gentoo.org>
Fri, 29 Dec 2006 23:18:50 +0000 (23:18 +0000)
Package-Manager: portage-2.1.2_rc4-r1

dev-python/adns-python/ChangeLog
dev-python/adns-python/adns-python-1.1.1.ebuild [new file with mode: 0644]
dev-python/adns-python/files/adns-python-1.1.1-adns-1.3.patch [new file with mode: 0644]
dev-python/adns-python/files/digest-adns-python-1.1.1 [new file with mode: 0644]

index 11bc543d77a46598af9152122579dcdd74bd3f6a..7a801aef3fa1115e755a987de007ee3e38de322f 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for dev-python/adns-python
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/adns-python/ChangeLog,v 1.13 2006/09/13 18:08:51 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/adns-python/ChangeLog,v 1.14 2006/12/29 23:18:50 dev-zero Exp $
+
+*adns-python-1.1.1 (29 Dec 2006)
+
+  29 Dec 2006; Tiziano Müller <dev-zero@gentoo.org>
+  +files/adns-python-1.1.1-adns-1.3.patch, -adns-python-1.1.0.ebuild,
+  +adns-python-1.1.1.ebuild:
+  Version bump. Fixed bug #150558 (thanks to Fabrice Delliaux) and depend now
+  on >=adns-1.3
 
   31 July 2006; Tom Gall <tgall@gentoo.org> adns-python-1.1.0.ebuild:
   added ~ppc64
diff --git a/dev-python/adns-python/adns-python-1.1.1.ebuild b/dev-python/adns-python/adns-python-1.1.1.ebuild
new file mode 100644 (file)
index 0000000..ff08785
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/adns-python/adns-python-1.1.1.ebuild,v 1.1 2006/12/29 23:18:50 dev-zero Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Python bindings for ADNS"
+HOMEPAGE="http://dustman.net/andy/python/adns-python"
+SRC_URI="http://dustman.net/andy/python/${PN}/${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=net-libs/adns-1.3"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}/${P}-adns-1.3.patch"
+}
diff --git a/dev-python/adns-python/files/adns-python-1.1.1-adns-1.3.patch b/dev-python/adns-python/files/adns-python-1.1.1-adns-1.3.patch
new file mode 100644 (file)
index 0000000..fac89d7
--- /dev/null
@@ -0,0 +1,20 @@
+--- adnsmodule.c.old   2006-10-16 12:27:50.000000000 +0200
++++ adnsmodule.c       2006-10-16 12:28:05.000000000 +0200
+@@ -88,7 +88,7 @@
+ };
+ static _constant_class adns_rr[] = {
+-      { "typemask", adns__rrt_typemask },
++      { "typemask", adns_rrt_typemask },
+       { "deref", adns__qtf_deref },
+       { "mail822", adns__qtf_mail822 },
+       { "none", adns_r_none },
+@@ -184,7 +184,7 @@
+ {
+       PyObject *o, *rrs;
+       int i;
+-      adns_rrtype t = answer->type & adns__rrt_typemask;
++      adns_rrtype t = answer->type & adns_rrt_typemask;
+       adns_rrtype td = answer->type & adns__qtf_deref;
+       rrs = PyTuple_New(answer->nrrs);
diff --git a/dev-python/adns-python/files/digest-adns-python-1.1.1 b/dev-python/adns-python/files/digest-adns-python-1.1.1
new file mode 100644 (file)
index 0000000..2a6fc7d
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 f7a3e7e81f6c13859261b40a9b5dc130 adns-python-1.1.1.tar.gz 16422
+RMD160 12487eda944081980848809bca52c8d0c7f50692 adns-python-1.1.1.tar.gz 16422
+SHA256 998566e1425a9606a41533b9ca8be00573d98d76f59b07ba77a3709e243c9376 adns-python-1.1.1.tar.gz 16422