dev-libs/uriparser: Improve on QA issues
authorSebastian Pipping <sping@gentoo.org>
Mon, 5 Oct 2015 16:25:42 +0000 (18:25 +0200)
committerSebastian Pipping <sping@gentoo.org>
Mon, 5 Oct 2015 16:25:44 +0000 (18:25 +0200)
.. pointed out by @hasufell at
https://github.com/gentoo/gentoo/commit/2114f96d146d19c46c6b6849ccc22b4a278d8730

dev-libs/uriparser/uriparser-0.8.3.ebuild

index de49e8c1b9cf021b698ed833c1f6157ab25e9228..a52452d55d6d60118bcf567a0ce1db7f8d8d7c36 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=4
+EAPI=5
 
 DESCRIPTION="Uriparser is a strictly RFC 3986 compliant URI parsing library in C"
 HOMEPAGE="http://uriparser.sourceforge.net/"
@@ -28,16 +28,15 @@ src_configure() {
                --enable-char \
                $(use_enable unicode wchar_t) \
                $(use_enable doc) \
-               --disable-dependency-tracking \
                --docdir=/usr/share/doc/${PF}/
 }
 
 src_install() {
-       emake DESTDIR="${D}" install || die "make install failed"
-       dodoc AUTHORS ChangeLog THANKS || die
+       emake DESTDIR="${D}" install
+       dodoc AUTHORS ChangeLog THANKS
 
        if use doc && use qt4; then
-               insinto /usr/share/doc/${PF}/
-               doins doc/*.qch || die  # Using doins to avoid dodoc's compression
+               dodoc doc/*.qch
+               docompress -x /usr/share/doc/${PF}/${P}.qch
        fi
 }