dev-perl/Fuse: revision bump, add missing deps, EAPI 7
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Thu, 17 Oct 2019 04:12:52 +0000 (06:12 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Thu, 17 Oct 2019 04:13:51 +0000 (06:13 +0200)
Closes: https://bugs.gentoo.org/697012
Closes: https://github.com/gentoo/gentoo/pull/13217
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
dev-perl/Fuse/Fuse-0.16.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Fuse/Fuse-0.16.1-r1.ebuild b/dev-perl/Fuse/Fuse-0.16.1-r1.ebuild
new file mode 100644 (file)
index 0000000..02c10a4
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DPATES
+inherit perl-module
+
+DESCRIPTION="Fuse module for perl"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="sys-fs/fuse"
+RDEPEND="
+       sys-fs/fuse:=
+       dev-perl/Filesys-Statvfs
+       dev-perl/Lchown
+       dev-perl/Unix-Mknod
+"
+BDEPEND="
+       virtual/perl-ExtUtils-MakeMaker
+       test? ( ${RDEPEND} )
+"