games-roguelike/dwarf-fortress: Remove old
authorChris Reffett <creffett@gentoo.org>
Mon, 28 Aug 2017 23:25:27 +0000 (19:25 -0400)
committerChris Reffett <creffett@gentoo.org>
Mon, 28 Aug 2017 23:25:27 +0000 (19:25 -0400)
Package-Manager: Portage-2.3.8, Repoman-2.3.3

games-roguelike/dwarf-fortress/Manifest
games-roguelike/dwarf-fortress/dwarf-fortress-0.40.24.ebuild [deleted file]
games-roguelike/dwarf-fortress/dwarf-fortress-0.42.06.ebuild [deleted file]

index eda79ad45cb485478eb67271e1b41c9d86c9d7cd..7f706d633ee1d33bd39ce4cd804d5e14c9180e75 100644 (file)
@@ -1,4 +1,2 @@
-DIST df_40_24_linux.tar.bz2 12921246 SHA256 da37c6263a679123e6ac57fe0dd6def11f1d61efee3c5913de09495c88ce9234 SHA512 2242e471b7dbc996e819e2f74b2bbfda30a9a301755bc025ddcccdffdd3afe2e48bbedca31a332283ef829d023069398e57d6a87e26c582ddbce4a67ff7fd755 WHIRLPOOL 03cb652a2564d2b0c809be8252f7754d893f69ac1b95124ea108ed0fde9ac742c498d9e369339775695861e430a2ded0741b018f85551d48731730f98303dc69
-DIST df_42_06_linux.tar.bz2 13857747 SHA256 03df8e73bf81e4f7bec9e789a83f8bd20b0b968d73131e4051e005db13fec99f SHA512 dfeb1406dcbd74091170eee4392c8eb876516d723b17e8aa291cab5b670be9fca4e22122788656e37afc03cd0e827e42b8cd27bc148d32639ebb7b8b7fa2bbf4 WHIRLPOOL d8fd93e9d90b4bee942c9a3751d1d03180157e4ecf406cf1cf31441946588990b2385a0b8d376f2a5386d7514d28b7ba5a6fbd2879e3a1e87124d902759909c3
 DIST df_43_05_linux.tar.bz2 11580594 SHA256 856c13170e8beefb5419ae71ee26c85db9716b3ebd4c7348aa44b896bd490be4 SHA512 502e6bac0bdd5586fb6b4e1117caf144a0336a7eed3ed9350ec316e4a286e309a15e0738517c0dd7d32f182984c501c7a8756e942d3dde9fb87f72b153f38e7a WHIRLPOOL 2ba6091c575eb7e2ca282e2192c0ca30ee48bfea473a0537acabfe33b2b7e848d1057f65409f9cc4aa2ec42f3c2dc7fef22139d3b2a788a84e71338a2c767ba1
 DIST df_43_05_linux32.tar.bz2 12158550 SHA256 0334e6b35ecc36949f5c60ffc1eb46fade3365b55a44f2e11fd4ae799ba7819a SHA512 d0446ddb5c37ee45ade36b18b815595e8d7bfd9749af4ecd2f25b45859d797a9da70f2344e2c58544feafc7df06882ade8a10534c37754359747c0d37f084b7c WHIRLPOOL 899d8739847cb37cb636453e7a728a0ae9765958fd77828e7f099b1f4b7a4bdaae0fee93121ddc81a0f2bf5ab4292380c9edb405dc5ed64d3d3cecf26f5f23c7
diff --git a/games-roguelike/dwarf-fortress/dwarf-fortress-0.40.24.ebuild b/games-roguelike/dwarf-fortress/dwarf-fortress-0.40.24.ebuild
deleted file mode 100644 (file)
index 03d564f..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils games multilib versionator
-
-MY_PV=$(replace_all_version_separators _ "$(get_version_component_range 2-)")
-MY_PN=df
-MY_P=${MY_PN}_${MY_PV}
-
-DESCRIPTION="A single-player fantasy game"
-HOMEPAGE="http://www.bay12games.com/dwarves"
-SRC_URI="http://www.bay12games.com/dwarves/${MY_P}_linux.tar.bz2"
-
-LICENSE="free-noncomm BSD BitstreamVera"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 -*"
-IUSE="debug"
-
-RDEPEND="media-libs/glew[abi_x86_32(-)]
-       media-libs/libsdl[abi_x86_32(-),opengl,video,X]
-       media-libs/libsndfile[abi_x86_32(-),alsa]
-       media-libs/sdl-image[abi_x86_32(-),jpeg,png,tiff]
-       media-libs/sdl-ttf[abi_x86_32(-)]
-       sys-libs/zlib[abi_x86_32(-)]
-       virtual/glu[abi_x86_32(-)]
-       x11-libs/gtk+:2[abi_x86_32(-)]"
-# Yup, openal and ncurses are only needed at compile-time; the code dlopens it at runtime
-# if requested.
-DEPEND="${RDEPEND}
-       media-libs/openal[abi_x86_32(-)]
-       sys-libs/ncurses[abi_x86_32(-),unicode]
-       virtual/pkgconfig
-       x11-proto/kbproto[abi_x86_32(-)]
-       x11-proto/xproto[abi_x86_32(-)]"
-
-S=${WORKDIR}/${MY_PN}_linux
-
-gamesdir="${GAMES_PREFIX_OPT}/${PN}"
-QA_PRESTRIPPED="${gamesdir}/libs/Dwarf_Fortress"
-
-pkg_setup() {
-       games_pkg_setup
-
-       multilib_toolchain_setup x86
-}
-
-src_prepare() {
-       rm libs/*.so*
-       cp "${FILESDIR}"/{dwarf-fortress,Makefile} .
-       epatch_user
-}
-
-src_configure() {
-       tc-export CXX PKG_CONFIG
-       CXXFLAGS+=" -D$(use debug || echo N)DEBUG"
-}
-
-src_compile() {
-       default
-       sed -i -e "s:^gamesdir=.*:gamesdir=${gamesdir}:" ${PN} || die
-}
-
-src_install() {
-       # install data-files and libs
-       insinto "${gamesdir}"
-       doins -r raw data libs
-
-       # install our wrapper
-       dogamesbin ${PN}
-
-       # install docs
-       dodoc README.linux *.txt
-
-       prepgamesdirs
-
-       fperms 750 "${gamesdir}"/libs/Dwarf_Fortress
-}
-
-pkg_postinst() {
-       elog "System-wide Dwarf Fortress has been installed to ${gamesdir}. This is"
-       elog "symlinked to ~/.dwarf-fortress when dwarf-fortress is run."
-       elog "For more information on what exactly is replaced, see ${GAMES_BINDIR}/${PN}."
-       elog "Note: This means that the primary entry point is ${GAMES_BINDIR}/${PN}."
-       elog "Do not run ${gamesdir}/libs/Dwarf_Fortress."
-       elog
-       elog "Optional runtime dependencies: install sys-libs/ncurses[$(use amd64 && echo "abi_x86_32,")unicode]"
-       elog "for [PRINT_MODE:TEXT]. Install media-libs/openal$(use amd64 && echo "[abi_x86_32]") for audio output."
-       elog
-       games_pkg_postinst
-}
diff --git a/games-roguelike/dwarf-fortress/dwarf-fortress-0.42.06.ebuild b/games-roguelike/dwarf-fortress/dwarf-fortress-0.42.06.ebuild
deleted file mode 100644 (file)
index 7cd47dd..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils games multilib versionator
-
-MY_PV=$(replace_all_version_separators _ "$(get_version_component_range 2-)")
-MY_PN=df
-MY_P=${MY_PN}_${MY_PV}
-
-DESCRIPTION="A single-player fantasy game"
-HOMEPAGE="http://www.bay12games.com/dwarves"
-SRC_URI="http://www.bay12games.com/dwarves/${MY_P}_linux.tar.bz2"
-
-LICENSE="free-noncomm BSD BitstreamVera"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 -*"
-IUSE="debug"
-
-RDEPEND="media-libs/glew[abi_x86_32(-)]
-       media-libs/libsdl[abi_x86_32(-),opengl,video,X]
-       media-libs/libsndfile[abi_x86_32(-),alsa]
-       media-libs/sdl-image[abi_x86_32(-),jpeg,png,tiff]
-       media-libs/sdl-ttf[abi_x86_32(-)]
-       sys-libs/zlib[abi_x86_32(-)]
-       virtual/glu[abi_x86_32(-)]
-       x11-libs/gtk+:2[abi_x86_32(-)]"
-# Yup, openal and ncurses are only needed at compile-time; the code dlopens it at runtime
-# if requested.
-DEPEND="${RDEPEND}
-       media-libs/openal[abi_x86_32(-)]
-       sys-libs/ncurses[abi_x86_32(-),unicode]
-       virtual/pkgconfig
-       x11-proto/kbproto[abi_x86_32(-)]
-       x11-proto/xproto[abi_x86_32(-)]"
-
-S=${WORKDIR}/${MY_PN}_linux
-
-gamesdir="${GAMES_PREFIX_OPT}/${PN}"
-QA_PRESTRIPPED="${gamesdir}/libs/Dwarf_Fortress"
-RESTRICT="strip"
-
-pkg_setup() {
-       games_pkg_setup
-
-       multilib_toolchain_setup x86
-}
-
-src_prepare() {
-       rm libs/*.so*
-       cp "${FILESDIR}"/{dwarf-fortress,Makefile} .
-       epatch_user
-}
-
-src_configure() {
-       tc-export CXX PKG_CONFIG
-       CXXFLAGS+=" -D$(use debug || echo N)DEBUG"
-}
-
-src_compile() {
-       default
-       sed -i -e "s:^gamesdir=.*:gamesdir=${gamesdir}:" ${PN} || die
-}
-
-src_install() {
-       # install data-files and libs
-       insinto "${gamesdir}"
-       doins -r raw data libs
-
-       # install our wrapper
-       dogamesbin ${PN}
-
-       # install docs
-       dodoc README.linux *.txt
-
-       prepgamesdirs
-
-       fperms 750 "${gamesdir}"/libs/Dwarf_Fortress
-}
-
-pkg_postinst() {
-       elog "System-wide Dwarf Fortress has been installed to ${gamesdir}. This is"
-       elog "symlinked to ~/.dwarf-fortress when dwarf-fortress is run."
-       elog "For more information on what exactly is replaced, see ${GAMES_BINDIR}/${PN}."
-       elog "Note: This means that the primary entry point is ${GAMES_BINDIR}/${PN}."
-       elog "Do not run ${gamesdir}/libs/Dwarf_Fortress."
-       elog
-       elog "Optional runtime dependencies: install sys-libs/ncurses[$(use amd64 && echo "abi_x86_32,")unicode]"
-       elog "for [PRINT_MODE:TEXT]. Install media-libs/openal$(use amd64 && echo "[abi_x86_32]") for audio output."
-       elog
-       games_pkg_postinst
-}