net-libs/socket_wrapper: Bump to version 1.1.4
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 26 Aug 2015 09:31:36 +0000 (11:31 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 26 Aug 2015 09:31:36 +0000 (11:31 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-libs/socket_wrapper/Manifest
net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild [new file with mode: 0644]

index deae4ad9a0d9549363c68da92161a8978a16371a..c87220f42aeb25b63dd0c4a9beb930bbec08c3fa 100644 (file)
@@ -1 +1,2 @@
 DIST socket_wrapper-1.1.3.tar.gz 50412 SHA256 a337db45f451495e6f095510add1e2a3e7a9dc399dd6a7aa1f462a063d51ae13 SHA512 691cd1db877661959d8ded6fe4df8c8e2e4300b2c800897bd3ecf62ea24dcc634188376ba4377868dbd67a8156af3051f53311b7320873b2daead91645473b5a WHIRLPOOL 9009ee4516111e31bd263d91163fc8e1ff7367420dcdc8283b38ea3ab0e9d990639c3804ba3861609af30a65f714629cea465b72dce58b671242b043865c7d04
+DIST socket_wrapper-1.1.4.tar.gz 51193 SHA256 535c85950df029b8f583d6757394666dce52ebc9affb62eb95c4c25cba3ef77a SHA512 a747c7a7c1eaf745c169574d29e920f2350bf77310649180253cc9fe7dd54a872d487604ac24e33a4046866bad3dd9e3b1c7f93dae7b1bcd6638e479acec27ec WHIRLPOOL 98792e8de06b41901f18691ab7e574c369a3559e813a0afdeb16ab319dfa33c285e1e1c97dff57923e0a2989ace0c8904ab56669e65a99790bf465d659b8d971
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild
new file mode 100644 (file)
index 0000000..c1a6edf
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multilib-minimal
+
+DESCRIPTION="A library passing all socket communications through unix sockets"
+HOMEPAGE="https://cwrap.org/socket_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+       cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+       cmake-utils_src_compile
+}
+
+multilib_src_install() {
+       cmake-utils_src_install
+}