app-backup/backintime: Version bump.
authorMichael Weber <xmw@gentoo.org>
Mon, 18 Dec 2017 16:43:29 +0000 (17:43 +0100)
committerMichael Weber <xmw@gentoo.org>
Mon, 18 Dec 2017 16:43:41 +0000 (17:43 +0100)
Closes: https://bugs.gentoo.org/628790
Package-Manager: Portage-2.3.19, Repoman-2.3.6

app-backup/backintime/Manifest
app-backup/backintime/backintime-1.1.24.ebuild [new file with mode: 0644]

index 87f86166eae2ec62b0f768969d1673ffdab1ef3c..c38d9099b5fdb7d3d58ad84989349819ef466470 100644 (file)
@@ -1 +1,2 @@
 DIST backintime-1.1.12.tar.gz 656192 BLAKE2B 724a3836a816fa921b6f150bc4214f01c200766d2be3e9a28bf3a818b1e43c73d73ca43bb52bacc9950d22be3faacfcee8f88a20f00362ea18cda236f3b2bd38 SHA512 e1dc3e3d2bac8b0f390898029978e806128ffd6005471a7e8a697c44f9e271f9902b496b33b037133f9a509f4ca3f8b8f10adf681b670ec9a1a751dfc786cb62
+DIST backintime-1.1.24.tar.gz 658961 BLAKE2B 88255ea138f31c4540f54d2053616d4c8ce35f7c969b15a9c46422bfed4f0fd2cabb01e0cd4d1505fb84eee31daacb9da36c6bf71225f5b9a1d47d6941e571b2 SHA512 d16b6d3a710154ca8bddf80a8f06835efe84dd2f2435102e06a732f7e6e291b1954864298542658bab2b7bc42d5a6bf1d9338a98c66fd3f888c450b9685cc011
diff --git a/app-backup/backintime/backintime-1.1.24.ebuild b/app-backup/backintime/backintime-1.1.24.ebuild
new file mode 100644 (file)
index 0000000..0868b0b
--- /dev/null
@@ -0,0 +1,87 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit eutils python-single-r1 gnome2-utils
+
+DESCRIPTION="Backup system inspired by TimeVault and FlyBack, with a GUI for GNOME and KDE4"
+HOMEPAGE="https://backintime.readthedocs.io/"
+SRC_URI="https://github.com/bit-team/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt4"
+
+DEPEND="${PYTHON_DEPS}
+       dev-python/dbus-python[${PYTHON_USEDEP}]
+       dev-python/keyring[${PYTHON_USEDEP}]
+       net-misc/openssh
+       net-misc/rsync[xattr,acl]"
+RDEPEND="${DEPEND}
+       qt4? ( dev-python/PyQt4 )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+       #fix doc install location
+       sed -e "s:/doc/${PN}-common:/doc/${PF}:g" \
+               -i common/configure || die
+       sed -e "s:/doc/${PN}-qt4:/doc/${PF}:g" \
+               -i qt4/configure || die
+       sed -e "/addInstallFile \"..\/VERSION/d" \
+               -e "/addInstallFile \"..\/LICENSE/d" \
+               -e "/addInstallFile \"..\/debian\/copyright/d" \
+               -i {qt4,common}/configure || die
+
+       if [ -n ${LINGUAS+x} ] ; then
+               cd common/po || die
+               for po in *.po ; do
+                       if ! has ${po/.po} ${LINGUAS} ; then
+                               rm ${po} || die
+                       fi
+               done
+       fi
+
+       default
+}
+
+src_configure() {
+       cd "${S}"/common || die
+       ./configure --python3 --no-fuse-group || die
+       if use qt4 ; then
+               cd "${S}"/qt4 || die
+               ./configure --python3 || die
+       fi
+}
+
+src_compile() {
+       cd "${S}"/common || die
+       emake
+       if use qt4 ; then
+               cd "${S}"/qt4 || die
+               emake
+       fi
+}
+
+src_install() {
+       cd "${S}"/common || die
+       emake DESTDIR="${D}" install
+       if use qt4 ; then
+               cd "${S}"/qt4 || die
+               emake DESTDIR="${D}" install
+       fi
+
+       python_optimize "${D}"
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}