dev-python/lit: Drop old (5.0.1 & 6.0.0)
authorMichał Górny <mgorny@gentoo.org>
Sun, 22 Jul 2018 07:20:32 +0000 (09:20 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 22 Jul 2018 08:22:44 +0000 (10:22 +0200)
dev-python/lit/Manifest
dev-python/lit/lit-5.0.1.ebuild [deleted file]
dev-python/lit/lit-6.0.0.ebuild [deleted file]

index 17ac1c399f4423a6c55c6058d6bfd06bb14f14db..7bbcae3ee6d036856d5ed97118c99a8c8471e2f7 100644 (file)
@@ -1,6 +1,4 @@
 DIST llvm-3.9.0.src.tar.xz 18235716 BLAKE2B c348d36cb21e716e8656b97489a0b7223fe81599e36ebf6f88d6191b1dec9eafc2d5d5413657ef89473af193b660c4b13317bebe5ecd02ad6c761c0ffdbe7f40 SHA512 f18ae32531218ab156c3e56c11826be0fd05f0799c82eaf2e6a043b38e1277560b4d921987513b88b11d97ea2619feaf277eec72181dd2ae4f4108c2836bf7b2
 DIST llvm-4.0.1.src.tar.xz 21065652 BLAKE2B 6327eed2d1feb108440f22d2581d1ff86c10a10c29793538d8d899c7e2dc83d3f7b147d3fd4bcce2bd2bf57c071b08c624aeafe40a3e7a3914506e7751727e6c SHA512 16adc39b34ddb628f81b171119a8e2a0e9138b25011e803ef0b688e2fbea116fc4953d3a1b61b90a98a75e33619f81566b7cb06a9a2ea4d04ac5e0eb303a2d1d
-DIST llvm-5.0.1.src.tar.xz 23428720 BLAKE2B 3db4d33df21018d17eef0042c0d8d82a8412bd5daa99cfb5405a6ec83c5774178fa76b220e8731c2a9a64dabf898aa90fe29c685327bd63a4f078e8e94a9a77e SHA512 bee1d45fca15ce725b1f2b1339b13eb6f750a3a321cfd099075477ec25835a8ca55b5366172c4aad46592dfd8afe372349ecf264f581463d017f9cee2d63c1cb
 DIST llvm-5.0.2.src.tar.xz 23451868 BLAKE2B b7082be2e4ad557b29b9f6869811f262adcf5c73d552faf91b339bede75cf5eab58afefa12fa779a38be71fe2b8f4ea297c3213ee4e8370cc01972c59249d91c SHA512 3588be5ed969c3f7f6f16f56a12a6af2814d3d3c960d4a36ffebb0446cc75f19220bccee7fc605f9b01f5d5c188a905a046193cc12dec42dd5922048b5c27fe1
-DIST llvm-6.0.0.src.tar.xz 25296048 BLAKE2B 7ea90bb63d6f26cfbc1c1ed2f243b0fcd8ad2ceb7963cf768d262cd55e9a0c71a9cfdea0333fb220faacf4540d924d2512532774dcfb52b52490ad74e38c09e0 SHA512 a71fdd5ddc46f01327ad891cfcc198febdbe10769c57f14d8a4fb7d514621ee4080e1a641200d3353c16a16731d390270499ec6cd3dc98fadc570f3eb6b52b8c
 DIST llvm-6.0.1.src.tar.xz 25306628 BLAKE2B 60232d4d22f8096b565cc8d81fea0639f24f14e8fc4f66ade69fa15479181f07f655f26dff3fa24bf105762b495da316c5c9352db234bd0af6b9c3fff6d4d881 SHA512 cbbb00eb99cfeb4aff623ee1a5ba075e7b5a76fc00c5f9f539ff28c108598f5708a0369d5bd92683def5a20c2fe60cab7827b42d628dbfcc79b57e0e91b84dd9
diff --git a/dev-python/lit/lit-5.0.1.ebuild b/dev-python/lit/lit-5.0.1.ebuild
deleted file mode 100644 (file)
index eb53b1c..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1
-
-MY_P=llvm-${PV/_/}.src
-DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
-HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 x86 ~amd64-fbsd"
-IUSE="test"
-
-S=${WORKDIR}/${MY_P}/utils/lit
-
-# Tests require 'FileCheck' and 'not' utilities (from llvm)
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/psutil[${PYTHON_USEDEP}]
-               sys-devel/llvm )"
-
-# TODO: move the manpage generation here (from sys-devel/llvm)
-
-src_unpack() {
-       einfo "Unpacking parts of ${MY_P}.tar.xz ..."
-       tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/lit" || die
-}
-
-python_test() {
-       ./lit.py -sv tests || die
-}
diff --git a/dev-python/lit/lit-6.0.0.ebuild b/dev-python/lit/lit-6.0.0.ebuild
deleted file mode 100644 (file)
index 59bae5b..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1 multiprocessing
-
-MY_P=llvm-${PV/_/}.src
-DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
-HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-S=${WORKDIR}/${MY_P}/utils/lit
-
-# Tests require 'FileCheck' and 'not' utilities (from llvm)
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/psutil[${PYTHON_USEDEP}]
-               sys-devel/llvm )"
-
-# TODO: move the manpage generation here (from sys-devel/llvm)
-
-src_unpack() {
-       einfo "Unpacking parts of ${MY_P}.tar.xz ..."
-       tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/lit" || die
-}
-
-python_test() {
-       ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
-               -vv tests || die
-}