app-editors/scite: Version Bump to 4.3.3.
authorErvin Peters <coder@ervnet.de>
Mon, 27 Apr 2020 04:51:52 +0000 (06:51 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 28 Apr 2020 07:44:07 +0000 (10:44 +0300)
Actual enhancements and upstream bugfixes. See
http://www.scintilla.org/ScintillaHistory.html

Signed-off-by: Ervin Peters <coder@ervnet.de>
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Closes: https://github.com/gentoo/gentoo/pull/15538
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-editors/scite/Manifest
app-editors/scite/scite-4.3.3.ebuild [new file with mode: 0644]

index 808dd3f0d0e24770c4cd3c86e3201469c6a71d63..212ac9a7c22557a3b63468a5064f9effc55cb8dd 100644 (file)
@@ -2,3 +2,4 @@ DIST scite-4.1.3.tgz 2546247 BLAKE2B 9c0cd767e6aff861bb706500eebf5fa431d5ce608f3
 DIST scite-4.2.0.tgz 2629884 BLAKE2B f9801146a086faefb38b72d28e00da055191c44254e5a6d34ade06462febd6a2b596aa572dd7e16c7541b0fcc23ff5f97f462b8869440782fd51f71ddd16d4c9 SHA512 d0a46ed2a21057a4fa866ae9305c9893360376d8591a9414eab96f9cb91991a43f3bf824bbb9a00c606555686aafdc0dc4b4bb41bcc94fe5dc90064342914c5a
 DIST scite-4.2.1.tgz 2633438 BLAKE2B cddf23f60eb1791266e38eba03ed8708aa02e0d91470344b19bfad7519930691a4b6a79b1eed3ac06234509b20fbd6b299c13c48a6990e0d8ced1a99a1d01220 SHA512 b2ad499f1c4d1a15b009516d24186c7d84f48ccdd40d2e9ca614de3cf36725a710523beaacda499186f040869e87339c2292e23eec959c2cdaa5fedfbb94d565
 DIST scite-4.3.2.tgz 2710026 BLAKE2B dd53eb2c3214033976ae4c5f63f75ea19d691ac9362e9d8ed527aff6b34d16e029d404d9731e3097cdf36d4c4594b427aa26bc9b83cb6a6ed05741e61fe4dfd4 SHA512 fd29369787f16c8357ae4bfd82b7f621ebb399e93e77c7540296c2a3c8b4e403071359f67f59bb5bd59216ae7e9cfa8aabfc38e200d59bea2c13e96991a3c9b8
+DIST scite-4.3.3.tgz 2714086 BLAKE2B f31db7147c102ea19317d5a0bfb64e2ccd34914a8b615cd6c02f2e79f1788433dd3ecd6a565599d43a0c4da34ac30e9434037a042d77170f14969d3b008a742f SHA512 85bc76bc9bb817fb0f7ddecad5e01d83d7090e788c2f74b9b23a86284f452a62c2fed64d0cf7c24cb57043228b8c91212742b644756d2ab185b10ead8785b82b
diff --git a/app-editors/scite/scite-4.3.3.ebuild b/app-editors/scite/scite-4.3.3.ebuild
new file mode 100644 (file)
index 0000000..e34188a
--- /dev/null
@@ -0,0 +1,113 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs xdg-utils
+
+DESCRIPTION="A very powerful, highly configurable, small editor with syntax coloring"
+HOMEPAGE="http://www.scintilla.org/SciTE.html"
+SRC_URI="https://www.scintilla.org/${PN}${PV//./}.tgz -> ${P}.tgz"
+
+LICENSE="HPND lua? ( MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="lua"
+
+RDEPEND="
+       dev-libs/glib:2
+       x11-libs/cairo
+       x11-libs/gdk-pixbuf
+       x11-libs/gtk+:3
+       x11-libs/pango
+       lua? ( >=dev-lang/lua-5:= )"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+       virtual/pkgconfig"
+
+DOCS=("../README")
+
+S="${WORKDIR}/${PN}/gtk"
+
+pkg_pretend() {
+       if tc-is-clang ; then
+               # need c++17 features
+               [[ "${MERGE_TYPE}" != "binary" &&
+               $(clang-major-version) -lt 5 ]] &&
+               die "Sorry, SCiTE uses C++17 Features and needs >sys-devel/clang-5
+               ($(clang-major-version))."
+
+       elif tc-is-gcc; then
+               # older gcc is not supported
+               [[ "${MERGE_TYPE}" != "binary" &&
+               $(gcc-major-version) -lt 7 ]] &&
+               die "Sorry, Scite uses C++17 Features, need >sys-devel/gcc-7."
+       else
+               die "Either gcc or clang should be configured for building scite"
+       fi
+}
+
+src_prepare() {
+       # remove hardcoded CC, Optimizations and clang unknown flags
+       sed -i "${WORKDIR}/scintilla/gtk/makefile" \
+       -e "s#^CC = gcc#CC = ${CC}#" \
+       -e "s#^CC = clang#CC = ${CC}#" \
+       -e "s#^CXX = clang++#CC = ${CXX}#" \
+       -e "s#-Os##" \
+       -e "s#-Wno-misleading-indentation##" \
+       || die "error patching /scintilla/gtk/makefile"
+
+       sed -i "${S}/makefile" \
+       -e "s#^CC = clang#CC = ${CC}#" \
+       -e "s#^CXX = clang++#CC = ${CXX}#" \
+       -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
+       -e "s#-Os##" \
+       || die "error patching gtk/makefile"
+
+       # repair and enhance the .desktop file
+       sed -i "${S}/SciTE.desktop" \
+       -e "s#text/plain#text/\*;application/xhtml+xml#" \
+       -e "s#^Categories=\(.*\)#Categories=Development;#" \
+       || die "error patching /scite/gtk/SciTe.desktop"
+
+       #  add the ebuild suffix as shell type for working with ebuilds
+       sed -i "${WORKDIR}/scite/src/perl.properties" \
+       -e "s#\*.sh;\*.bsh;#\*.ebuild;\*.sh;\*.bsh;#" \
+       || die "error patching /scite/src/perl.prperties"
+
+       # it seems that pwd here is ${S}, but user patches are relative to ${workdir}
+       # Bug #576162
+
+       cd "${WORKDIR}" || die "couldn't cd into ${WORKDIR}"
+       eapply_user
+}
+
+src_compile() {
+       # prepare make options
+       local emake_pars=("GTK3=1")
+
+       tc-is-clang && emake_pars+=("CLANG=1")
+       use !lua    && emake_pars+=("NO_LUA=1")
+
+       emake -C "${WORKDIR}/scintilla/gtk" "${emake_pars[@]}"
+       emake "${emake_pars[@]}"
+}
+
+# want to use the base src_install() as base_src_install()
+
+src_install() {
+       default
+       dosym SciTE /usr/bin/scite
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+       xdg_desktop_database_update
+}