media-tv/mythtv: additional bug fixes
authorDoug Goldstein <cardoe@gentoo.org>
Wed, 9 Sep 2015 03:26:39 +0000 (22:26 -0500)
committerDoug Goldstein <cardoe@gentoo.org>
Wed, 9 Sep 2015 03:27:03 +0000 (22:27 -0500)
Fix the usage of $EPYTHON. Added call to --disable-vdpau and
--disable-crystalhd when their respective USE flags are disabled. Finish
conversion to python-single-r1.

Package-Manager: portage-2.2.20.1
Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
media-tv/mythtv/mythtv-0.27.5_p20150904.ebuild

index 23a2b365430fa1e05297f95b0f394a44beea9f8b..9a16f8025d79a7eccfae28948183fd935385c1ca 100644 (file)
@@ -217,7 +217,7 @@ src_configure() {
                myconf="${myconf} --without-bindings=perl,python"
        fi
 
-       use python && myconf="${myconf} --python=$(EPYTHON)"
+       use python && myconf="${myconf} --python=${EPYTHON}"
 
        if use debug; then
                myconf="${myconf} --compile-type=debug"
@@ -228,9 +228,9 @@ src_configure() {
        fi
 
        # Video
-       use vdpau && myconf="${myconf} --enable-vdpau"
+       myconf="${myconf} $(use_enable vdpau)"
        myconf="${myconf} $(use_enable vaapi)"
-       use crystalhd && myconf="${myconf} --enable-crystalhd"
+       myconf="${myconf} $(use_enable crystalhd)"
 
        # Input
        use input_devices_joystick || myconf="${myconf} --disable-joystick-menu"
@@ -321,7 +321,7 @@ src_install() {
        done
 
        # Ensure that Python scripts are executed by Python 2
-       python_convert_shebangs -q -r 2 "${ED}/usr/share/mythtv"
+       python_fix_shebang "${ED}/usr/share/mythtv"
 
        # Make shell & perl scripts executable
        find "${ED}" -type f -name '*.sh' -o -type f -name '*.pl' | \
@@ -335,8 +335,6 @@ pkg_preinst() {
 }
 
 pkg_postinst() {
-       use python && python_mod_optimize MythTV
-
        elog "To have this machine operate as recording host for MythTV, "
        elog "mythbackend must be running. Run the following:"
        elog "rc-update add mythbackend default"
@@ -352,10 +350,6 @@ pkg_postinst() {
        elog "to journald via the console at the notice verbosity."
 }
 
-pkg_postrm() {
-       use python && python_mod_cleanup MythTV
-}
-
 pkg_info() {
        if [[ -f "${EROOT}"/usr/bin/mythfrontend ]]; then
                "${EROOT}"/usr/bin/mythfrontend --version