media-tv/kodi: Fix compiling with >=dev-libs/libfmt-6.1.0
authorCraig Andrews <candrews@gentoo.org>
Fri, 6 Dec 2019 17:04:57 +0000 (12:04 -0500)
committerCraig Andrews <candrews@gentoo.org>
Fri, 6 Dec 2019 17:07:51 +0000 (12:07 -0500)
Closes: https://bugs.gentoo.org/702104
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Craig Andrews <candrews@gentoo.org>
media-tv/kodi/files/kodi-18.5-cassert.patch [new file with mode: 0644]
media-tv/kodi/kodi-18.5.ebuild
media-tv/kodi/kodi-9999.ebuild

diff --git a/media-tv/kodi/files/kodi-18.5-cassert.patch b/media-tv/kodi/files/kodi-18.5-cassert.patch
new file mode 100644 (file)
index 0000000..9558baa
--- /dev/null
@@ -0,0 +1,42 @@
+https://github.com/xbmc/xbmc/pull/17000
+
+From bbfc36f06c191d3bdea19cacc498afb86bd25404 Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Thu, 5 Dec 2019 14:49:50 -0500
+Subject: [PATCH] Add missing cassert includes
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Without these includes, â€˜assert’ was not declared in this scope errors
+occur.
+---
+ xbmc/profiles/dialogs/GUIDialogProfileSettings.cpp | 1 +
+ xbmc/windowing/GraphicContext.cpp                  | 2 ++
+ 2 files changed, 3 insertions(+)
+
+diff --git a/xbmc/profiles/dialogs/GUIDialogProfileSettings.cpp b/xbmc/profiles/dialogs/GUIDialogProfileSettings.cpp
+index 1303d894478c..aa85d95b3234 100644
+--- a/xbmc/profiles/dialogs/GUIDialogProfileSettings.cpp
++++ b/xbmc/profiles/dialogs/GUIDialogProfileSettings.cpp
+@@ -31,6 +31,7 @@
+ #include "utils/Variant.h"
+ #include "utils/log.h"
++#include <cassert>
+ #include <utility>
+ #define SETTING_PROFILE_NAME          "profile.name"
+diff --git a/xbmc/windowing/GraphicContext.cpp b/xbmc/windowing/GraphicContext.cpp
+index b47bafba57dc..75b333ea6daa 100644
+--- a/xbmc/windowing/GraphicContext.cpp
++++ b/xbmc/windowing/GraphicContext.cpp
+@@ -25,6 +25,8 @@
+ #include "settings/lib/Setting.h"
+ #include "utils/log.h"
++#include <cassert>
++
+ using namespace KODI::MESSAGING;
+ CGraphicContext::CGraphicContext(void) = default;
index e4a919d0debeec7026ab7ce10669a83992ac778c..f8dc1e17074916d1022dc95e42d02cb6feae92f7 100644 (file)
@@ -14,6 +14,9 @@ SRC_URI="https://github.com/xbmc/libdvdcss/archive/${LIBDVDCSS_VERSION}.tar.gz -
        https://github.com/xbmc/libdvdread/archive/${LIBDVDREAD_VERSION}.tar.gz -> libdvdread-${LIBDVDREAD_VERSION}.tar.gz
        https://github.com/xbmc/libdvdnav/archive/${LIBDVDNAV_VERSION}.tar.gz -> libdvdnav-${LIBDVDNAV_VERSION}.tar.gz
        !system-ffmpeg? ( https://github.com/xbmc/FFmpeg/archive/${FFMPEG_VERSION}-${CODENAME}-${FFMPEG_KODI_VERSION}.tar.gz -> ffmpeg-${PN}-${FFMPEG_VERSION}-${CODENAME}-${FFMPEG_KODI_VERSION}.tar.gz )"
+PATCHES=(
+       "${FILESDIR}/${P}-cassert.patch"
+)
 
 if [[ ${PV} == *9999 ]] ; then
        PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
index d44644c1f23ac2f15f73bd77350c4831db28c5b3..30fee14a9351ba6164e5914d1219c5f9f317572d 100644 (file)
@@ -15,7 +15,9 @@ SRC_URI="https://github.com/xbmc/libdvdcss/archive/${LIBDVDCSS_VERSION}.tar.gz -
        https://github.com/xbmc/libdvdread/archive/${LIBDVDREAD_VERSION}.tar.gz -> libdvdread-${LIBDVDREAD_VERSION}.tar.gz
        https://github.com/xbmc/libdvdnav/archive/${LIBDVDNAV_VERSION}.tar.gz -> libdvdnav-${LIBDVDNAV_VERSION}.tar.gz
        !system-ffmpeg? ( https://github.com/xbmc/FFmpeg/archive/${FFMPEG_VERSION}-${CODENAME}-${FFMPEG_KODI_VERSION}.tar.gz -> ffmpeg-${PN}-${FFMPEG_VERSION}-${CODENAME}-${FFMPEG_KODI_VERSION}.tar.gz )"
-
+PATCHES=(
+       "${FILESDIR}/${PN}-18.5-cassert.patch"
+)
 if [[ ${PV} == *9999 ]] ; then
        EGIT_REPO_URI="https://github.com/xbmc/xbmc.git"
        inherit git-r3