sci-biology/samtools: Remove python dependency
authorDavid Seifert <soap@gentoo.org>
Fri, 27 Mar 2020 10:35:24 +0000 (11:35 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 27 Mar 2020 10:35:24 +0000 (11:35 +0100)
Closes: https://bugs.gentoo.org/710252
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: David Seifert <soap@gentoo.org>
sci-biology/samtools/samtools-1.9-r1.ebuild [moved from sci-biology/samtools/samtools-1.9.ebuild with 72% similarity]

similarity index 72%
rename from sci-biology/samtools/samtools-1.9.ebuild
rename to sci-biology/samtools/samtools-1.9-r1.ebuild
index bdcd115aafeee9c4883588f01316770f214e82b6..0d0f993895fcb40346827d82472f222b16e10bc3 100644 (file)
@@ -1,11 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools python-single-r1 toolchain-funcs
+inherit autotools toolchain-funcs
 
 DESCRIPTION="Utilities for analysing and manipulating the SAM/BAM alignment formats"
 HOMEPAGE="http://www.htslib.org/"
@@ -15,22 +13,18 @@ LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
 IUSE="examples"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="
        dev-lang/perl
        =sci-libs/htslib-${PV}*
        sys-libs/ncurses:0=
-       sys-libs/zlib:=
-       ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
+       sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
 
 src_prepare() {
        default
 
-       python_fix_shebang misc/varfilter.py
-
        # remove bundled htslib
        rm -r htslib-* || die
 
@@ -45,6 +39,9 @@ src_test() {
 src_install() {
        default
 
+       # varfilter.py has been retired upstream for being py2 only
+       rm "${ED}"/usr/bin/varfilter.py || die
+
        if use examples; then
                dodoc -r examples
                docompress -x /usr/share/doc/${PF}/examples