sys-devel/llvm: Port 9+ to llvm.org.eclass
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 17:37:48 +0000 (18:37 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 3 Nov 2019 11:46:09 +0000 (12:46 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/llvm/llvm-10.0.0.9999.ebuild
sys-devel/llvm/llvm-9.0.0.ebuild
sys-devel/llvm/llvm-9.0.1.9999.ebuild

index 467c5badf2e50c30cd95b838ccb51fc7a333f288..ac0af7a686a05638c2b877eebad72c4e438aa876 100644 (file)
@@ -4,14 +4,13 @@
 EAPI=7
 
 PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils git-r3 multilib-minimal multiprocessing pax-utils \
-       python-any-r1 toolchain-funcs
+inherit cmake-utils llvm.org multilib-minimal multiprocessing \
+       pax-utils python-any-r1 toolchain-funcs
 
 DESCRIPTION="Low Level Virtual Machine"
 HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-S=${WORKDIR}/${P}/llvm
+LLVM_COMPONENTS=( llvm )
+llvm.org_set_globals
 
 # Those are in lib/Targets, without explicit CMakeLists.txt mention
 ALL_LLVM_EXPERIMENTAL_TARGETS=( ARC AVR )
@@ -87,11 +86,6 @@ python_check_deps() {
        has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
 }
 
-src_unpack() {
-       git-r3_fetch
-       git-r3_checkout '' '' '' llvm
-}
-
 check_live_ebuild() {
        local prod_targets=(
                $(sed -n -e '/set(LLVM_ALL_TARGETS/,/)/p' CMakeLists.txt \
index 96e7ec6b1e751abcc7cb02f5bf6beca191229105..a01238a0f7525c15502f468ac15d2de1b0caa3db 100644 (file)
@@ -4,15 +4,15 @@
 EAPI=7
 
 PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils multilib-minimal multiprocessing pax-utils \
-       python-any-r1 toolchain-funcs
+inherit cmake-utils llvm.org multilib-minimal multiprocessing \
+       pax-utils python-any-r1 toolchain-funcs
 
-MY_P=${P}.src
 DESCRIPTION="Low Level Virtual Machine"
 HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz
+SRC_URI="
        !doc? ( https://dev.gentoo.org/~mgorny/dist/llvm/${P}-manpages.tar.bz2 )"
-S=${WORKDIR}/${MY_P}
+LLVM_COMPONENTS=( llvm )
+llvm.org_set_globals
 
 # Keep in sync with CMakeLists.txt
 ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
@@ -84,6 +84,16 @@ python_check_deps() {
        has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
 }
 
+src_unpack() {
+       llvm.org_src_unpack
+
+       if ! use doc; then
+               ebegin "Unpacking llvm-${PV}-manpages.tar.bz2"
+               tar -xf "${DISTDIR}/llvm-${PV}-manpages.tar.bz2" || die
+               eend
+       fi
+}
+
 src_prepare() {
        # Fix llvm-config for shared linking and sane flags
        # https://bugs.gentoo.org/show_bug.cgi?id=565358
index 26723e46b9126fad313ba7d5213e4d743eaf348b..2f2597f5b16df9a0748168356e3cb83f22681bc1 100644 (file)
@@ -4,15 +4,13 @@
 EAPI=7
 
 PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils git-r3 multilib-minimal multiprocessing pax-utils \
-       python-any-r1 toolchain-funcs
+inherit cmake-utils llvm.org multilib-minimal multiprocessing \
+       pax-utils python-any-r1 toolchain-funcs
 
 DESCRIPTION="Low Level Virtual Machine"
 HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-EGIT_BRANCH="release/9.x"
-S=${WORKDIR}/${P}/llvm
+LLVM_COMPONENTS=( llvm )
+llvm.org_set_globals
 
 # Keep in sync with CMakeLists.txt
 ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
@@ -84,11 +82,6 @@ python_check_deps() {
        has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
 }
 
-src_unpack() {
-       git-r3_fetch
-       git-r3_checkout '' '' '' llvm
-}
-
 src_prepare() {
        # Fix llvm-config for shared linking and sane flags
        # https://bugs.gentoo.org/show_bug.cgi?id=565358