sys-libs/libsmbios: Bump to version 2.4.3
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 10 Feb 2020 13:02:11 +0000 (14:02 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 10 Feb 2020 13:02:34 +0000 (14:02 +0100)
Default enable "python" USE flag.

Closes: https://bugs.gentoo.org/708290
Closes: https://bugs.gentoo.org/708288
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-libs/libsmbios/Manifest
sys-libs/libsmbios/libsmbios-2.4.3.ebuild [new file with mode: 0644]

index 49464a42fb098d35b45b516cd9ad5f726d17cf81..a55b7cb2abbb6606200065019e36946fdce7d5e8 100644 (file)
@@ -1 +1,2 @@
 DIST libsmbios-2.4.2.tar.gz 668042 BLAKE2B 2106206dce95e481ae36e033d2abe9f39402368a09686b92fd1de7d85e87ea494514e85bdf1267adb6b52060a4e6bb6001714c5d891a4c0342c814942c0458af SHA512 51d1b11447d50b768658473d01bcb6cc7f9dd5c96c26ec343f222115ffb5047ca1f035a0bfb67f94f53165eaea7a0d9b70cf01f03333a30885bbac153bf761bd
+DIST libsmbios-2.4.3.tar.gz 644140 BLAKE2B 684bff4f6cf755796f785e9a93d4ddbe2a1af52082cdebc27d203772a6a2a0259edb4b9d19921f90fc78b48d54700223fbc2628665b963ebcb601010ff4340ab SHA512 7f6fb36fa9653e123b416b275953fb5652025e76dac3b4ec5600168e193ea56f8ac3ea1a3b5db29d2770e73d88152d712a35bf77a9b3fc5596570fae885585ad
diff --git a/sys-libs/libsmbios/libsmbios-2.4.3.ebuild b/sys-libs/libsmbios/libsmbios-2.4.3.ebuild
new file mode 100644 (file)
index 0000000..4e9e41d
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools flag-o-matic python-single-r1
+
+DESCRIPTION="Provide access to (SM)BIOS information"
+HOMEPAGE="http://linux.dell.com/files/libsmbios/"
+SRC_URI="https://github.com/dell/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 OSL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="doc graphviz nls +python static-libs test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/libxml2
+       sys-libs/zlib
+       nls? ( virtual/libintl )
+       python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       doc? ( app-doc/doxygen )
+       graphviz? ( media-gfx/graphviz )
+       nls? ( sys-devel/gettext )
+       test? ( >=dev-util/cppunit-1.9.6 )"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-2.2.28-cppunit-tests.patch"
+)
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       # Don't build yum-plugin - we don't need it
+       sed '/yum-plugin/d' -i Makefile.am || die
+
+       eautoreconf
+}
+
+src_configure() {
+       #Remove -O3 for bug #290097
+       replace-flags -O3 -O2
+
+       local myeconfargs=(
+               $(use_enable doc doxygen)
+               $(use_enable graphviz)
+               $(use_enable nls)
+               $(use_enable python)
+               $(use_enable static-libs static)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       emake install DESTDIR="${D}"
+
+       if use python ; then
+               python_scriptinto /usr/sbin
+               python_doscript "${ED}"/usr/sbin/smbios-{{keyboard,thermal,token,wakeup,wireless}-ctl,lcd-brightness,passwd,sys-info}
+       fi
+
+       insinto /usr/include/
+       doins -r src/include/smbios_c
+
+       einstalldocs
+
+       if ! use static-libs ; then
+               find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+       fi
+}