dev-python/python-cjson: initial import of version 1.1.0
authorJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 00:46:31 +0000 (02:46 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 17:40:14 +0000 (19:40 +0200)
Gentoo-Bug: 446188

dev-python/python-cjson/Manifest [new file with mode: 0644]
dev-python/python-cjson/metadata.xml [new file with mode: 0644]
dev-python/python-cjson/python-cjson-1.1.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-cjson/Manifest b/dev-python/python-cjson/Manifest
new file mode 100644 (file)
index 0000000..8f27ee0
--- /dev/null
@@ -0,0 +1,2 @@
+DIST python-cjson-1.1.0.tar.gz 12298 SHA256 a01fabb7593728c3d851e1cd9a3efbd18f72650a31a5aa8a74018640da3de8b3 SHA512 039e5f724c3a49d0043f788b0634c4191a6ae5abaa012d8491622e5a9ac22ecc5a342a0243f70b0ac02c8640243aaf8b0cf20a0ab12ee4866d9af966d73c1706 WHIRLPOOL 509817683798ef7e9dd7a22c13bff52ce5eb48cdf4aed996603b89fe8d8270e24e90f240adcd14efd1d5326c45edb4f440269e32b7bcb445409a83d44baf067f
+EBUILD python-cjson-1.1.0.ebuild 580 SHA256 ebf8ea33fffacc8f3993319e4f1e28a51abf951e0d4bf804791ee26597c13fe8 SHA512 191bac2ca1396427f932b554bda9c978c6bdbb2318f992ebe2f2fc355f8e54eb7ec1ebb25d4be773aaede9a357dd1ab9c34a29aad19ca6d729e928078a515690 WHIRLPOOL d10bd60c40525345ac62b8ff20d1e19c1709965d6e0963c5207114edd4e66c831c85cc4349e13cb819539b1bab2a7ccadd2cb77c965acd40e36e79a1848ffe0c
diff --git a/dev-python/python-cjson/metadata.xml b/dev-python/python-cjson/metadata.xml
new file mode 100644 (file)
index 0000000..2018cab
--- /dev/null
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>python</herd>
+       <maintainer>
+               <email>hasufell@gentoo.org</email>
+               <name>Julian Ospald</name>
+       </maintainer>
+       <longdescription lang="en">
+               This module implements a very fast JSON encoder/decoder for Python.
+
+               JSON stands for JavaScript Object Notation and is a text based
+               lightweight data exchange format which is easy for humans to
+               read/write and for machines to parse/generate. JSON is completely
+               language independent and has multiple implementations in most of
+               the programming languages, making it ideal for data exchange and
+               storage.
+
+               The module is written in C and it is up to 250 times faster when
+               compared to the other python JSON implementations which are written
+               directly in python. This speed gain varies with the complexity of
+               the data and the operation and is the the range of 10-200 times for
+               encoding operations and in the range of 100-250 times for decoding
+               operations.
+       </longdescription>
+       <upstream>
+               <remote-id type="pypi">python-cjson</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-cjson/python-cjson-1.1.0.ebuild b/dev-python/python-cjson/python-cjson-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..cb2dfd7
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast JSON encoder/decoder for Python"
+HOMEPAGE="http://ag-projects.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"