dev-ros/poco_vendor: use python-any-r1
authorAlexis Ballier <aballier@gentoo.org>
Fri, 13 Dec 2019 11:47:20 +0000 (12:47 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 13 Dec 2019 11:48:38 +0000 (12:48 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild
dev-ros/poco_vendor/poco_vendor-9999.ebuild

index ed5cfd5207ede7d1f8d0cb6781186a76765668cb..b6214810f35f8d1aa00cfaf55b632cf1376367ca 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python{3_6,3_7} )
 
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
 
 if [ "${PV#9999}" != "${PV}" ] ; then
        inherit git-r3
@@ -31,16 +31,7 @@ DEPEND="
        dev-libs/poco
 "
 RDEPEND="${DEPEND}"
-BDEPEND="ros-meta/ament_cmake[${PYTHON_USEDEP}]
+BDEPEND="
+       $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
        ${PYTHON_DEPS}
 "
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
-       # This is a build tool that does not install python-related files
-       # ... but we need to propagate the deps and use python3 to build it.
-       local pyimpl="${PYTHON_COMPAT[0]}"
-       python_export "${pyimpl}" EPYTHON PYTHON
-       python_wrapper_setup
-       cmake-utils_src_configure
-}
index ed5cfd5207ede7d1f8d0cb6781186a76765668cb..b6214810f35f8d1aa00cfaf55b632cf1376367ca 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python{3_6,3_7} )
 
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
 
 if [ "${PV#9999}" != "${PV}" ] ; then
        inherit git-r3
@@ -31,16 +31,7 @@ DEPEND="
        dev-libs/poco
 "
 RDEPEND="${DEPEND}"
-BDEPEND="ros-meta/ament_cmake[${PYTHON_USEDEP}]
+BDEPEND="
+       $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
        ${PYTHON_DEPS}
 "
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
-       # This is a build tool that does not install python-related files
-       # ... but we need to propagate the deps and use python3 to build it.
-       local pyimpl="${PYTHON_COMPAT[0]}"
-       python_export "${pyimpl}" EPYTHON PYTHON
-       python_wrapper_setup
-       cmake-utils_src_configure
-}