sci-biology/ariadne: Modernise to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Sun, 26 Feb 2017 19:16:40 +0000 (20:16 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 26 Feb 2017 19:18:38 +0000 (20:18 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-biology/ariadne/ariadne-1.3-r3.ebuild [new file with mode: 0644]
sci-biology/ariadne/files/ariadne-1.3-gcc4.patch

diff --git a/sci-biology/ariadne/ariadne-1.3-r3.ebuild b/sci-biology/ariadne/ariadne-1.3-r3.ebuild
new file mode 100644 (file)
index 0000000..8be74e1
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Protein sequences and profiles comparison"
+HOMEPAGE="http://www.well.ox.ac.uk/ariadne/"
+SRC_URI="http://www.well.ox.ac.uk/${PN}/${P}.tar.Z"
+
+LICENSE="ARIADNE"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sci-biology/ncbi-tools-0.20041020-r1"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/SRC-${PV}
+
+PATCHES=(
+       "${FILESDIR}"/${P}-gcc4.patch
+       "${FILESDIR}"/${P}-implicits.patch
+)
+
+src_prepare() {
+       default
+       sed -i -e "s/\$(CFLAGS)/\$(LDFLAGS) &/" Makefile || die #359045
+       sed -e "s/blosum62/BLOSUM62/" -i prospero.c || die
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)" OPTIMISE="${CFLAGS}"
+}
+
+src_install() {
+       dobin Linux/{ariadne,prospero}
+
+       use static-libs && dolib.a Linux/libseq.a
+
+       insinto /usr/include/${PN}
+       doins Include/*.h
+
+       einstalldocs
+}
index 0192efd4db5e029e8be770bdaf79f06a61db560a..8bda75cb4f3a2e9c0da9889fa495baa8d4cff99d 100644 (file)
@@ -1,5 +1,5 @@
---- cl.c.old   2006-09-12 17:13:02.000000000 -0400
-+++ cl.c       2006-09-12 17:13:34.000000000 -0400
+--- a/cl.c
++++ b/cl.c
 @@ -658,6 +658,7 @@
        fclose(fp);
        if ( ! stat( filename, &buf ) )