dev-python/pydocstyle: Version bump to 5.0.2
authorMatt Turner <mattst88@gentoo.org>
Sat, 15 Feb 2020 20:31:36 +0000 (12:31 -0800)
committerMatt Turner <mattst88@gentoo.org>
Sat, 15 Feb 2020 20:42:38 +0000 (12:42 -0800)
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-python/pydocstyle/Manifest
dev-python/pydocstyle/metadata.xml
dev-python/pydocstyle/pydocstyle-5.0.2.ebuild [new file with mode: 0644]

index 4fae544a37611301657874a4d3b490ec437f84da..e0085d8746af53f14a3ed19b0d8828b4540f8e5d 100644 (file)
@@ -1 +1,2 @@
 DIST pydocstyle-2.1.1.tar.gz 55760 BLAKE2B e470b006b5db04c4bed5c3145b14b949980c71d1dd91dbe34d49599063aaf1cb1d0842dfb992e5d471436446455bde2d309ee573826c039540fa99adba3f828b SHA512 f23939e0350094c67565613bab4ddf285dda5a7379e6ac2493953d6e60ab75588143fd374715765d2aa0728e7117d02e91312dbbe5a9cad28aa8e8e7f68e3bc4
+DIST pydocstyle-5.0.2.tar.gz 68063 BLAKE2B 6d7bf04e97c853e50d953342d332847d0e80b080d5ab044f9d444536ed0352ad44402a1af0c3a6f552ec9f3bb3a372a84af2a5bbdaee58bb18dab585cad5dddb SHA512 5ac2e017ae95ff5c7759d6a2cb9ac990f94f668f5fd940792d927cc62628cd036afcf39ab5db6a11100dcca32af344b47f4a7319dd3a47c36367844d0c06d34a
index 6425ffb95a7d5883f3c9c4333dc715301517eaca..17a622fcf6bad72223c5c9e0e706474f42ce7cc5 100644 (file)
@@ -9,6 +9,14 @@
     <email>monsieurp@gentoo.org</email>
     <name>Patrice Clement</name>
   </maintainer>
+  <maintainer type="person">
+    <email>andrewammerlaan@riseup.net</email>
+    <name>Andrew Ammerlaan</name>
+  </maintainer>
+  <maintainer type="project">
+    <email>proxy-maint@gentoo.org</email>
+    <name>Proxy Maintainers</name>
+  </maintainer>
   <upstream>
     <remote-id type="github">PyCQA/pydocstyle</remote-id>
     <remote-id type="pypi">pydocstyle</remote-id>
diff --git a/dev-python/pydocstyle/pydocstyle-5.0.2.ebuild b/dev-python/pydocstyle/pydocstyle-5.0.2.ebuild
new file mode 100644 (file)
index 0000000..65c6d9c
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python docstring style checker"
+HOMEPAGE="https://github.com/PyCQA/pydocstyle/"
+SRC_URI="https://github.com/PyCQA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/snowballstemmer[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+       dev-python/pytest-pep8[${PYTHON_USEDEP}]
+       dev-python/mypy[${PYTHON_USEDEP}]
+       dev-python/tox[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-issuetracker
+
+src_prepare() {
+       default
+
+       # These tests call pip.
+       # pip install fails because we are not allowed to do that inside an ebuild.
+       rm ${S}/src/tests/test_integration.py || die
+}