app-arch/cpio: backport tweak for gcc-10, bug #705900
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 18 Feb 2020 20:46:27 +0000 (20:46 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Tue, 18 Feb 2020 20:46:27 +0000 (20:46 +0000)
Closes: https://bugs.gentoo.org/705900
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
app-arch/cpio/cpio-2.12-r1.ebuild
app-arch/cpio/cpio-2.13.ebuild
app-arch/cpio/files/cpio-2.12-gcc-10.patch [new file with mode: 0644]

index a32dcef968d0d55d25ea661833d311404423821d..2c74b76cbc14657be721f00ede5e995f75f867d1 100644 (file)
@@ -17,6 +17,7 @@ IUSE="nls"
 src_prepare() {
        epatch "${FILESDIR}"/${PN}-2.12-non-gnu-compilers.patch #275295
        epatch "${FILESDIR}"/${PN}-2.12-name-overflow.patch #572428
+       epatch "${FILESDIR}"/${PN}-2.12-gcc-10.patch #705900
 }
 
 src_configure() {
index 30557dbd0433f4fd80f0fb1c6b9b8c906d506fa9..4f5966691a58404e9fc509f645c1728d2c8bfd6c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -14,6 +14,7 @@ IUSE="nls"
 
 PATCHES=(
        "${FILESDIR}"/${PN}-2.12-non-gnu-compilers.patch #275295
+       "${FILESDIR}"/${PN}-2.12-gcc-10.patch #705900
 )
 
 src_configure() {
diff --git a/app-arch/cpio/files/cpio-2.12-gcc-10.patch b/app-arch/cpio/files/cpio-2.12-gcc-10.patch
new file mode 100644 (file)
index 0000000..9c7d7ed
--- /dev/null
@@ -0,0 +1,27 @@
+From 641d3f489cf6238bb916368d4ba0d9325a235afb Mon Sep 17 00:00:00 2001
+From: Sergey Poznyakoff <gray@gnu.org>
+Date: Mon, 20 Jan 2020 07:45:39 +0200
+Subject: Minor fix * src/global.c: Remove superfluous declaration of
+ program_name
+
+---
+ src/global.c | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/src/global.c b/src/global.c
+index fb3abe9..acf92bc 100644
+--- a/src/global.c
++++ b/src/global.c
+@@ -184,9 +184,6 @@ unsigned int warn_option = 0;
+ /* Extract to standard output? */
+ bool to_stdout_option = false;
+-/* The name this program was run with.  */
+-char *program_name;
+-
+ /* A pointer to either lstat or stat, depending on whether
+    dereferencing of symlinks is done for input files.  */
+ int (*xstat) ();
+-- 
+cgit v1.2.1
+