dev-python/hcloud-python: remove old
authorAgostino Sarubbo <ago@gentoo.org>
Wed, 4 Mar 2020 10:29:51 +0000 (11:29 +0100)
committerAgostino Sarubbo <ago@gentoo.org>
Wed, 4 Mar 2020 10:29:51 +0000 (11:29 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
dev-python/hcloud-python/Manifest
dev-python/hcloud-python/hcloud-python-1.6.1.ebuild [deleted file]

index a10857572709fb7a066b3c34aebdc189a169b5b4..98d9fc275ea4fde828720450ae1969e0054dfe26 100644 (file)
@@ -1,2 +1 @@
-DIST hcloud-python-1.6.1.tar.gz 71866 BLAKE2B 0a1d37d4dc8be4e28595385ec7622ec65367c40f9cdd455e03827a5ee2983f43026b1dbb7e9bd20d241ed9a4748015d33bdcb53b15ce148c401984960e158716 SHA512 0b2ecaa311b4dac44b3122a45a38f76f8377bc189b1550f21327ea3f56fefad624ea6809c4abd6bbaf5c8fc23dfa5e6edd352dcbbcfae6c87af897ff376ce2cf
 DIST hcloud-python-1.6.3.tar.gz 71575 BLAKE2B a6c969d713d1351bba0cebef8752abbbf0805b4a39eedc918767ccf60d590ac8259e1405a25c2c563923146d52ae1318d6362cbaee311bfe04bea5afcc18951b SHA512 dec3f16197de9f02c2707601e1cad40289d3ccbd6256887da50b84fb8fe6b0fb98f708c9ba0cfc2ff1308a53b9997cfda579df3ec79a1d28686a3c43f4124e74
diff --git a/dev-python/hcloud-python/hcloud-python-1.6.1.ebuild b/dev-python/hcloud-python/hcloud-python-1.6.1.ebuild
deleted file mode 100644 (file)
index 91e6bbb..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Official Hetzner Cloud python library"
-HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
-SRC_URI="https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="doc examples"
-
-COMMON_DEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.20[${PYTHON_USEDEP}]
-       <dev-python/requests-2.23[${PYTHON_USEDEP}]"
-
-DEPEND="${COMMON_DEPEND}
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-RDEPEND="${COMMON_DEPEND}
-       dev-python/future[${PYTHON_USEDEP}]"
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_install_all() {
-       use examples && dodoc -r examples
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-
-       distutils-r1_python_install_all
-}