media-sound/picard: 2.3.1 + py38
authorSebastian Pipping <sping@gentoo.org>
Thu, 12 Mar 2020 15:33:23 +0000 (16:33 +0100)
committerSebastian Pipping <sping@gentoo.org>
Thu, 12 Mar 2020 15:35:52 +0000 (16:35 +0100)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.92, Repoman-2.3.20

media-sound/picard/Manifest
media-sound/picard/picard-2.3.1.ebuild [new file with mode: 0644]

index 3ebc38c83988f260837821ba1076e21bc2fcde58..7a49a7317027432d0257195c9d0b9194fd4e2d73 100644 (file)
@@ -1 +1,2 @@
 DIST picard-2.1.3.tar.gz 2995390 BLAKE2B dcb81cad62aba7915aeff321775452cef70819194a76530eb96a0a7b0009f7185d7652f77d07bb795b24939a3feb56b73a59d7377574b2c8f09f406ca7a88d81 SHA512 f082216a1a669ba689725c93859116e8a56991861219adb0e7c6ed4e5d621055268652820688de762f55b8672f19ff01afe5ac1ab7f79a640ea381272de9516f
+DIST picard-2.3.1.tar.gz 3778379 BLAKE2B b829c29d95922e31479cea0c8bcb3294cd3751374e71f37d387a013529c294a695a2e2f4c8b73af5eeee2fa8f7423d24074bc18b7db130798411803c70a013ff SHA512 fb5ac4cbd02f4b832cb23e3c8b5881eeca04b7b101c015a97fc20c8e0e7871ad2098b750a0c486af958b2bf30221b0c28666313f768dc7d70389519dd795d9cd
diff --git a/media-sound/picard/picard-2.3.1.ebuild b/media-sound/picard/picard-2.3.1.ebuild
new file mode 100644 (file)
index 0000000..86dadf0
--- /dev/null
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_SINGLE_IMPL=1
+DISABLE_AUTOFORMATTING=true
+inherit distutils-r1 gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Cross-platform music tagger"
+HOMEPAGE="https://picard.musicbrainz.org"
+SRC_URI="https://musicbrainz.osuosl.org/pub/musicbrainz/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+       $(python_gen_cond_dep '
+               dev-python/PyQt5[declarative,gui,network,widgets,${PYTHON_MULTI_USEDEP}]
+       ')
+       dev-qt/qtgui:5
+       >=media-libs/mutagen-1.38"
+DEPEND="
+       nls? ( dev-qt/linguist-tools:5 )
+"
+
+RESTRICT="test" # doesn't work with ebuilds
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+python_compile() {
+       local build_args=(
+               --disable-autoupdate
+       )
+       if ! use nls; then
+               build_args+=( --disable-locales )
+       fi
+       distutils-r1_python_compile ${build_args[@]}
+}
+
+python_install() {
+       local install_args=(
+               --disable-autoupdate
+               --skip-build
+       )
+       if ! use nls; then
+               install_args+=( --disable-locales )
+       fi
+       distutils-r1_python_install ${install_args[@]}
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       local DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
+calculation and lookup of AcoustID fingerprints.
+
+Install optional package dev-python/python-discid to enable
+calculation and lookup of compact disc identifiers (disc IDs).
+
+If you are upgrading Picard and it does not start, try removing
+Picard's settings:
+       rm ~/.config/MusicBrainz/Picard.conf"
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+       xdg_pkg_postinst
+}