app-misc/imgurbash2: New package
authorLucian Poston <lucianposton@pm.me>
Thu, 2 Aug 2018 00:10:59 +0000 (17:10 -0700)
committerMichał Górny <mgorny@gentoo.org>
Wed, 22 Aug 2018 20:31:15 +0000 (22:31 +0200)
Closes: https://bugs.gentoo.org/662620
Closes: https://github.com/gentoo/gentoo/pull/9416
Package-Manager: Portage-2.3.40, Repoman-2.3.9

app-misc/imgurbash2/Manifest [new file with mode: 0644]
app-misc/imgurbash2/imgurbash2-2.1.ebuild [new file with mode: 0644]
app-misc/imgurbash2/imgurbash2-9999.ebuild [new file with mode: 0644]
app-misc/imgurbash2/metadata.xml [new file with mode: 0644]

diff --git a/app-misc/imgurbash2/Manifest b/app-misc/imgurbash2/Manifest
new file mode 100644 (file)
index 0000000..2369147
--- /dev/null
@@ -0,0 +1 @@
+DIST imgurbash2-2.1.tar.gz 3619 BLAKE2B 01bb37615184113082a87b79b5bbda1707e36d8f4a28715e0686eb63f8d7c55f7aa760ecab9ab2457c1601e9cb0ff4b558cd08f8a77a123cfe97d8008ad1aa93 SHA512 32e7c39d3456f3d540af2db8b21d8a5724bf9b1db372953f3dd0ed21a6f7529209ec7afffe22410be46a99753202aca2454732d09c1314350187c5610b36ab9d
diff --git a/app-misc/imgurbash2/imgurbash2-2.1.ebuild b/app-misc/imgurbash2/imgurbash2-2.1.ebuild
new file mode 100644 (file)
index 0000000..076690d
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/ram-on/imgurbash2.git"
+else
+       SRC_URI="https://github.com/ram-on/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Bash script that uploads/deletes images to/from imgur"
+HOMEPAGE="https://github.com/ram-on/imgurbash2"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="
+       net-misc/curl
+       X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+"
+
+src_install() {
+       einstalldocs
+       dobin imgurbash2
+}
diff --git a/app-misc/imgurbash2/imgurbash2-9999.ebuild b/app-misc/imgurbash2/imgurbash2-9999.ebuild
new file mode 100644 (file)
index 0000000..076690d
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/ram-on/imgurbash2.git"
+else
+       SRC_URI="https://github.com/ram-on/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Bash script that uploads/deletes images to/from imgur"
+HOMEPAGE="https://github.com/ram-on/imgurbash2"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="
+       net-misc/curl
+       X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+"
+
+src_install() {
+       einstalldocs
+       dobin imgurbash2
+}
diff --git a/app-misc/imgurbash2/metadata.xml b/app-misc/imgurbash2/metadata.xml
new file mode 100644 (file)
index 0000000..080521c
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>lucianposton@pm.me</email>
+               <name>Lucian Poston</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">ram-on/imgurbash2</remote-id>
+       </upstream>
+</pkgmetadata>