x11-misc/evolvotron: fix build with gcc6, bug #597266
authorHarri Nieminen <moikkis@gmail.com>
Sun, 26 Feb 2017 16:46:13 +0000 (18:46 +0200)
committerDavid Seifert <soap@gentoo.org>
Tue, 28 Feb 2017 19:10:53 +0000 (20:10 +0100)
Gentoo-Bug: https://bugs.gentoo.org/597266

Package-Manager: Portage-2.3.3, Repoman-2.3.1
Closes: https://github.com/gentoo/gentoo/pull/4085

x11-misc/evolvotron/evolvotron-0.6.3-r1.ebuild [new file with mode: 0644]
x11-misc/evolvotron/files/evolvotron-0.6.3-gcc6.patch [new file with mode: 0644]

diff --git a/x11-misc/evolvotron/evolvotron-0.6.3-r1.ebuild b/x11-misc/evolvotron/evolvotron-0.6.3-r1.ebuild
new file mode 100644 (file)
index 0000000..6d52be1
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit qmake-utils
+
+DESCRIPTION="Generative art image evolver"
+HOMEPAGE="https://sourceforge.net/projects/evolvotron/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+       dev-libs/boost:=
+       dev-qt/qtcore:4
+       dev-qt/qtgui:4
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
+
+DOCS=( BUGS NEWS README TODO USAGE )
+HTML_DOCS=( evolvotron.html )
+
+src_configure() {
+       eqmake4 main.pro
+}
+
+src_compile() {
+       local etsubdir
+       for etsubdir in \
+               libfunction libevolvotron evolvotron evolvotron_render evolvotron_mutate
+               do
+               emake sub-${etsubdir}
+       done
+}
+
+src_install() {
+       local bin
+       for bin in ${PN}{,_mutate,_render}; do
+               dobin ${bin}/${bin}
+       done
+       doman man/man1/*
+       einstalldocs
+}
diff --git a/x11-misc/evolvotron/files/evolvotron-0.6.3-gcc6.patch b/x11-misc/evolvotron/files/evolvotron-0.6.3-gcc6.patch
new file mode 100644 (file)
index 0000000..709d61b
--- /dev/null
@@ -0,0 +1,15 @@
+Description: Fix compilation with GCC6 by making implict conversion to bool explicit
+Author: Axel Beckert <abe@debian.org>
+Bug-Debian: https://bugs.debian.org/811660
+
+--- a/libevolvotron/mutatable_image_computer.h
++++ b/libevolvotron/mutatable_image_computer.h
+@@ -193,7 +193,7 @@
+   //! Indicate whether computation us taking place (only intended for counting outstanding threads).
+   bool active() const
+     {
+-      return _task;
++      return (bool)_task;
+     }
+ };