sys-libs/ncurses: build the C++ libs as shared
authorMike Frysinger <vapier@gentoo.org>
Wed, 12 Aug 2015 10:22:17 +0000 (06:22 -0400)
committerMike Frysinger <vapier@gentoo.org>
Wed, 12 Aug 2015 10:38:08 +0000 (06:38 -0400)
Since upstream has a configure flag for this now, we should be able to
build+install the C++ layers as shared libs instead of only making the
static libs available.

sys-libs/ncurses/ncurses-6.0.ebuild

index 92adb1e58468611c763afee43edbd9786ce5ddab..7372e09a5895f04434670b943db57b5b6ef03e4f 100644 (file)
@@ -96,6 +96,7 @@ do_configure() {
                $(use_with ada)
                $(use_with cxx)
                $(use_with cxx cxx-binding)
+               --with-cxx-shared
                $(use_with debug)
                $(use_with profile)
                # The configure script uses ldd to parse the linked output which
@@ -181,7 +182,7 @@ multilib_src_install() {
        if ! tc-is-static-only ; then
                ln -sf libncurses$(get_libname) "${ED}"/usr/$(get_libdir)/libcurses$(get_libname) || die
        fi
-       use static-libs || find "${ED}"/usr/ -name '*.a' -a '!' -name '*curses++*.a' -delete
+       use static-libs || find "${ED}"/usr/ -name '*.a' -delete
 
        # Build fails to create this ...
        dosym ../share/terminfo /usr/$(get_libdir)/terminfo