media-sound/mpd: remove opts variable from init script
authorLouis Sautier <sautier.louis@gmail.com>
Sun, 27 May 2018 13:44:50 +0000 (15:44 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 2 Jun 2018 13:25:01 +0000 (15:25 +0200)
This variable should never have been used in the first place because it
is reserved to OpenRC. It is unlikely that this variable was ever used
because mpd exposes no interesting command-line options and Gentoo never
provided an associated conf.d file either.

Closes: https://bugs.gentoo.org/645664
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/8621

media-sound/mpd/files/mpd-0.20.4.init
media-sound/mpd/mpd-0.20.12-r1.ebuild [moved from media-sound/mpd/mpd-0.20.12.ebuild with 99% similarity]

index 3eb0bc2bcb82c78ba9ca1bcbe14c3c3f3dd4e79a..0a4c61677bcbb35b9b1bc859a038322cdad62fa7 100644 (file)
@@ -1,5 +1,5 @@
 #!/sbin/openrc-run
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 : CFGFILE=${CFGFILE:=/etc/mpd.conf}
@@ -20,7 +20,7 @@ get_config() {
 
 extra_started_commands='reload'
 command=/usr/bin/mpd
-command_args=${opts:=${CFGFILE}}
+command_args=${CFGFILE}
 required_files=${CFGFILE}
 pidfile=$(get_config pid_file)
 description="Music Player Daemon"
similarity index 99%
rename from media-sound/mpd/mpd-0.20.12.ebuild
rename to media-sound/mpd/mpd-0.20.12-r1.ebuild
index 856bef0460879a7cde357db4052f92920be8a470..413a9c53b12094d8daee4d2e6068e2cf418c530b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6