*/*: Switch graphics proj packages to cmake.eclass
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 30 Dec 2019 18:22:57 +0000 (19:22 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 31 Dec 2019 17:19:21 +0000 (18:19 +0100)
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
19 files changed:
media-gfx/darktable/darktable-2.6.2.ebuild
media-gfx/darktable/darktable-2.6.3.ebuild
media-gfx/darktable/darktable-3.0.0.ebuild
media-gfx/darktable/darktable-9999.ebuild
media-gfx/enblend/enblend-4.2.0_p20161007-r1.ebuild
media-gfx/gmic/gmic-2.7.0.ebuild
media-gfx/gmic/gmic-2.7.1.ebuild
media-gfx/gmic/gmic-2.7.2.ebuild
media-gfx/inkscape/inkscape-1.0_beta2.ebuild
media-gfx/inkscape/inkscape-9999.ebuild
media-gfx/luminance-hdr/luminance-hdr-2.6.0.ebuild
media-gfx/rawtherapee/rawtherapee-5.6.ebuild
media-gfx/rawtherapee/rawtherapee-5.7.ebuild
media-gfx/scantailor-advanced/scantailor-advanced-1.0.16.ebuild
media-libs/libharu/libharu-2.3.0-r2.ebuild
media-libs/libjpeg-turbo/libjpeg-turbo-2.0.3.ebuild
media-libs/opencolorio/opencolorio-1.1.0-r2.ebuild
media-libs/openimageio/openimageio-1.8.17-r1.ebuild
media-libs/openjpeg/openjpeg-2.3.1.ebuild

index 45b7d5db3effd5587e656b6fc18a0854ce314ad7..ee670e7183873404aebbcf5086a1f105a74e6466 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils flag-o-matic pax-utils toolchain-funcs xdg
+inherit cmake flag-o-matic pax-utils toolchain-funcs xdg
 
 DOC_PV="2.6.0"
 MY_PV="${PV/_/}"
@@ -86,7 +86,7 @@ pkg_pretend() {
 src_prepare() {
        use cpu_flags_x86_sse3 && append-flags -msse3
 
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
 
 src_configure() {
@@ -109,11 +109,11 @@ src_configure() {
                -DUSE_WEBP=$(usex webp)
        )
        CMAKE_BUILD_TYPE="RELWITHDEBINFO"
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        use doc && dodoc "${DISTDIR}"/${PN}-usermanual-${DOC_PV}.pdf
 
        if use nls ; then
index fcc4a9f8ffae3468071d1963e58b34c300a794ec..b08753b83535bcf5ef59574cf00e747459458181 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils flag-o-matic pax-utils toolchain-funcs xdg
+inherit cmake flag-o-matic pax-utils toolchain-funcs xdg
 
 DOC_PV="2.6.0"
 MY_PV="${PV/_/}"
@@ -84,7 +84,7 @@ pkg_pretend() {
 src_prepare() {
        use cpu_flags_x86_sse3 && append-flags -msse3
 
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
 
 src_configure() {
@@ -107,11 +107,11 @@ src_configure() {
                -DUSE_WEBP=$(usex webp)
        )
        CMAKE_BUILD_TYPE="RELWITHDEBINFO"
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        use doc && dodoc "${DISTDIR}"/${PN}-usermanual-${DOC_PV}.pdf
 
        if use nls ; then
index ae5f3039daafdc004cf142fe456be18b7ee844d4..c91fabeb3ab2e1b87d798c7c54c0ac5106cdebb2 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils flag-o-matic pax-utils toolchain-funcs xdg
+inherit cmake flag-o-matic pax-utils toolchain-funcs xdg
 
 DOC_PV="2.6.0"
 MY_PV="${PV/_/}"
@@ -84,7 +84,7 @@ pkg_pretend() {
 src_prepare() {
        use cpu_flags_x86_sse3 && append-flags -msse3
 
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
 
 src_configure() {
@@ -107,11 +107,11 @@ src_configure() {
                -DUSE_WEBP=$(usex webp)
        )
        CMAKE_BUILD_TYPE="RELWITHDEBINFO"
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        use doc && dodoc "${DISTDIR}"/${PN}-usermanual-${DOC_PV}.pdf
 
        if use nls ; then
index 6357db9016d57a751415052e6f11c0ec9888d333..111dc666f46f47f8cbf8c8e796746863e374f55b 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils flag-o-matic git-r3 pax-utils toolchain-funcs xdg
+inherit cmake flag-o-matic git-r3 pax-utils toolchain-funcs xdg
 
 EGIT_REPO_URI="https://github.com/darktable-org/${PN}.git"
 
@@ -73,7 +73,7 @@ pkg_pretend() {
 src_prepare() {
        use cpu_flags_x86_sse3 && append-flags -msse3
 
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
 
 src_configure() {
@@ -96,11 +96,11 @@ src_configure() {
                -DUSE_WEBP=$(usex webp)
        )
        CMAKE_BUILD_TYPE="RELWITHDEBINFO"
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        use doc && dodoc "${DISTDIR}"/${PN}-usermanual-${DOC_PV}.pdf
 
        if use nls ; then
index 51f0c069d6ee831539e8c38f98cf0063e27e49e1..9049ae5c5e7ba3eb948722872f9798ec4687b59a 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils
+inherit cmake
 
 DESCRIPTION="Image Blending with Multiresolution Splines"
 HOMEPAGE="http://enblend.sourceforge.net/"
@@ -52,7 +52,7 @@ PATCHES=(
 )
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        sed -i -e "s:share/doc/enblend:share/doc/${PF}:" doc/CMakeLists.txt || die
 }
@@ -70,7 +70,7 @@ src_configure() {
                -DINSTALL_PDF_DOC=ON
        fi
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_compile() {
@@ -81,5 +81,5 @@ src_compile() {
        export VARTEXFONTS="${T}/fonts"
 
        # forcing -j1 as every parallel compilation process needs about 1 GB RAM.
-       cmake-utils_src_compile -j1
+       cmake_src_compile -j1
 }
index d4bacf38744671ee1181f4006f09630c23fa5264..a96eb924674f8249efa888def3442adb0bc84e2f 100644 (file)
@@ -4,9 +4,7 @@
 EAPI=7
 
 CMAKE_BUILD_TYPE=Release
-CMAKE_MIN_VERSION=3.9
-
-inherit cmake-utils bash-completion-r1
+inherit cmake bash-completion-r1
 
 if [[ ${PV} == "9999" ]]; then
        EGIT_REPO_URI="https://github.com/dtschump/gmic.git"
@@ -81,14 +79,14 @@ pkg_pretend() {
 
 src_prepare() {
        local PATCHES=( "${FILESDIR}"/${PN}-2.4.3-curl.patch )
-       cmake-utils_src_prepare
+       cmake_src_prepare
        sed -i '/CMAKE_CXX_FLAGS/s/-g //' CMakeLists.txt || die
 
        if use gimp || use krita || use qt5; then
                sed -i '/CMAKE_CXX_FLAGS_RELEASE/d' gmic-qt/CMakeLists.txt || die
                local S="${S}/gmic-qt"
                PATCHES=( "${FILESDIR}"/${PN}-2.6.7-qt-cmake.patch )
-               cmake-utils_src_prepare
+               cmake_src_prepare
        fi
 }
 
@@ -115,7 +113,7 @@ src_configure() {
                -DENABLE_DYNAMIC_LINKING=ON
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 
        # configure gmic-qt frontends
        local CMAKE_USE_DIR="${S}/gmic-qt"
@@ -128,32 +126,32 @@ src_configure() {
 
        if use gimp; then
                mycmakeargs+=( -DGMIC_QT_HOST=gimp )
-               BUILD_DIR="${BUILD_DIR}"/gimp cmake-utils_src_configure
+               BUILD_DIR="${BUILD_DIR}"/gimp cmake_src_configure
        fi
 
        if use krita; then
                mycmakeargs+=( -DGMIC_QT_HOST=krita )
-               BUILD_DIR="${BUILD_DIR}"/krita cmake-utils_src_configure
+               BUILD_DIR="${BUILD_DIR}"/krita cmake_src_configure
        fi
 
        if use qt5; then
                mycmakeargs+=( -DGMIC_QT_HOST=none )
-               BUILD_DIR="${BUILD_DIR}"/qt5 cmake-utils_src_configure
+               BUILD_DIR="${BUILD_DIR}"/qt5 cmake_src_configure
        fi
 }
 
 src_compile() {
-       cmake-utils_src_compile
+       cmake_src_compile
 
        # build gmic-qt frontends
        local S="${S}/gmic-qt"
-       use gimp && { BUILD_DIR="${BUILD_DIR}"/gimp cmake-utils_src_compile || die "failed building gimp plugin" ; }
-       use krita && { BUILD_DIR="${BUILD_DIR}"/krita cmake-utils_src_compile || die "failed building krita plugin" ; }
-       use qt5 && { BUILD_DIR="${BUILD_DIR}"/qt5 cmake-utils_src_compile || die "failed building qt5 GUI" ; }
+       use gimp && { BUILD_DIR="${BUILD_DIR}"/gimp cmake_src_compile || die "failed building gimp plugin" ; }
+       use krita && { BUILD_DIR="${BUILD_DIR}"/krita cmake_src_compile || die "failed building krita plugin" ; }
+       use qt5 && { BUILD_DIR="${BUILD_DIR}"/qt5 cmake_src_compile || die "failed building qt5 GUI" ; }
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        dodoc README
        use cli && newbashcomp "${BUILD_DIR}"/resources/gmic_bashcompletion.sh ${PN}
 
index bd8a5d1a186b7cc8d0ff64a7b96126b443e71680..81708eba2f7242d9351708690073660e49ba1168 100644 (file)
@@ -4,9 +4,7 @@
 EAPI=7
 
 CMAKE_BUILD_TYPE=Release
-CMAKE_MIN_VERSION=3.9
-
-inherit cmake-utils bash-completion-r1
+inherit cmake bash-completion-r1
 
 if [[ ${PV} == "9999" ]]; then
        EGIT_REPO_URI="https://github.com/dtschump/gmic.git"
@@ -81,14 +79,14 @@ pkg_pretend() {
 
 src_prepare() {
        local PATCHES=( "${FILESDIR}"/${PN}-2.4.3-curl.patch )
-       cmake-utils_src_prepare
+       cmake_src_prepare
        sed -i '/CMAKE_CXX_FLAGS/s/-g //' CMakeLists.txt || die
 
        if use gimp || use krita || use qt5; then
                sed -i '/CMAKE_CXX_FLAGS_RELEASE/d' gmic-qt/CMakeLists.txt || die
                local S="${S}/gmic-qt"
                PATCHES=( "${FILESDIR}"/${PN}-2.7.1-qt-cmake.patch )
-               cmake-utils_src_prepare
+               cmake_src_prepare
        fi
 }
 
@@ -115,7 +113,7 @@ src_configure() {
                -DENABLE_DYNAMIC_LINKING=ON
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 
        # configure gmic-qt frontends
        local CMAKE_USE_DIR="${S}/gmic-qt"
@@ -128,32 +126,32 @@ src_configure() {
 
        if use gimp; then
                mycmakeargs+=( -DGMIC_QT_HOST=gimp )
-               BUILD_DIR="${BUILD_DIR}"/gimp cmake-utils_src_configure
+               BUILD_DIR="${BUILD_DIR}"/gimp cmake_src_configure
        fi
 
        if use krita; then
                mycmakeargs+=( -DGMIC_QT_HOST=krita )
-               BUILD_DIR="${BUILD_DIR}"/krita cmake-utils_src_configure
+               BUILD_DIR="${BUILD_DIR}"/krita cmake_src_configure
        fi
 
        if use qt5; then
                mycmakeargs+=( -DGMIC_QT_HOST=none )
-               BUILD_DIR="${BUILD_DIR}"/qt5 cmake-utils_src_configure
+               BUILD_DIR="${BUILD_DIR}"/qt5 cmake_src_configure
        fi
 }
 
 src_compile() {
-       cmake-utils_src_compile
+       cmake_src_compile
 
        # build gmic-qt frontends
        local S="${S}/gmic-qt"
-       use gimp && { BUILD_DIR="${BUILD_DIR}"/gimp cmake-utils_src_compile || die "failed building gimp plugin" ; }
-       use krita && { BUILD_DIR="${BUILD_DIR}"/krita cmake-utils_src_compile || die "failed building krita plugin" ; }
-       use qt5 && { BUILD_DIR="${BUILD_DIR}"/qt5 cmake-utils_src_compile || die "failed building qt5 GUI" ; }
+       use gimp && { BUILD_DIR="${BUILD_DIR}"/gimp cmake_src_compile || die "failed building gimp plugin" ; }
+       use krita && { BUILD_DIR="${BUILD_DIR}"/krita cmake_src_compile || die "failed building krita plugin" ; }
+       use qt5 && { BUILD_DIR="${BUILD_DIR}"/qt5 cmake_src_compile || die "failed building qt5 GUI" ; }
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        dodoc README
        use cli && newbashcomp "${BUILD_DIR}"/resources/gmic_bashcompletion.sh ${PN}
 
index bd8a5d1a186b7cc8d0ff64a7b96126b443e71680..81708eba2f7242d9351708690073660e49ba1168 100644 (file)
@@ -4,9 +4,7 @@
 EAPI=7
 
 CMAKE_BUILD_TYPE=Release
-CMAKE_MIN_VERSION=3.9
-
-inherit cmake-utils bash-completion-r1
+inherit cmake bash-completion-r1
 
 if [[ ${PV} == "9999" ]]; then
        EGIT_REPO_URI="https://github.com/dtschump/gmic.git"
@@ -81,14 +79,14 @@ pkg_pretend() {
 
 src_prepare() {
        local PATCHES=( "${FILESDIR}"/${PN}-2.4.3-curl.patch )
-       cmake-utils_src_prepare
+       cmake_src_prepare
        sed -i '/CMAKE_CXX_FLAGS/s/-g //' CMakeLists.txt || die
 
        if use gimp || use krita || use qt5; then
                sed -i '/CMAKE_CXX_FLAGS_RELEASE/d' gmic-qt/CMakeLists.txt || die
                local S="${S}/gmic-qt"
                PATCHES=( "${FILESDIR}"/${PN}-2.7.1-qt-cmake.patch )
-               cmake-utils_src_prepare
+               cmake_src_prepare
        fi
 }
 
@@ -115,7 +113,7 @@ src_configure() {
                -DENABLE_DYNAMIC_LINKING=ON
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 
        # configure gmic-qt frontends
        local CMAKE_USE_DIR="${S}/gmic-qt"
@@ -128,32 +126,32 @@ src_configure() {
 
        if use gimp; then
                mycmakeargs+=( -DGMIC_QT_HOST=gimp )
-               BUILD_DIR="${BUILD_DIR}"/gimp cmake-utils_src_configure
+               BUILD_DIR="${BUILD_DIR}"/gimp cmake_src_configure
        fi
 
        if use krita; then
                mycmakeargs+=( -DGMIC_QT_HOST=krita )
-               BUILD_DIR="${BUILD_DIR}"/krita cmake-utils_src_configure
+               BUILD_DIR="${BUILD_DIR}"/krita cmake_src_configure
        fi
 
        if use qt5; then
                mycmakeargs+=( -DGMIC_QT_HOST=none )
-               BUILD_DIR="${BUILD_DIR}"/qt5 cmake-utils_src_configure
+               BUILD_DIR="${BUILD_DIR}"/qt5 cmake_src_configure
        fi
 }
 
 src_compile() {
-       cmake-utils_src_compile
+       cmake_src_compile
 
        # build gmic-qt frontends
        local S="${S}/gmic-qt"
-       use gimp && { BUILD_DIR="${BUILD_DIR}"/gimp cmake-utils_src_compile || die "failed building gimp plugin" ; }
-       use krita && { BUILD_DIR="${BUILD_DIR}"/krita cmake-utils_src_compile || die "failed building krita plugin" ; }
-       use qt5 && { BUILD_DIR="${BUILD_DIR}"/qt5 cmake-utils_src_compile || die "failed building qt5 GUI" ; }
+       use gimp && { BUILD_DIR="${BUILD_DIR}"/gimp cmake_src_compile || die "failed building gimp plugin" ; }
+       use krita && { BUILD_DIR="${BUILD_DIR}"/krita cmake_src_compile || die "failed building krita plugin" ; }
+       use qt5 && { BUILD_DIR="${BUILD_DIR}"/qt5 cmake_src_compile || die "failed building qt5 GUI" ; }
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        dodoc README
        use cli && newbashcomp "${BUILD_DIR}"/resources/gmic_bashcompletion.sh ${PN}
 
index d88a546fcfbf8583645751b6efca8666fafe3d68..df86aac246d2d3968c9c4ec16a68fe532364096d 100644 (file)
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{5,6,7} )
 PYTHON_REQ_USE="xml"
 MY_P="${P/_/}"
 RELEASE_SUFFIX="_2019-12-03_2b71d25d45"
-inherit cmake-utils flag-o-matic xdg toolchain-funcs python-single-r1
+inherit cmake flag-o-matic xdg toolchain-funcs python-single-r1
 
 DESCRIPTION="SVG based generic vector-drawing program"
 HOMEPAGE="https://inkscape.org/"
@@ -109,7 +109,7 @@ pkg_pretend() {
 }
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
        sed -i "/install.*COPYING/d" CMakeScripts/ConfigCPack.cmake || die
 }
 
@@ -136,11 +136,11 @@ src_configure() {
                -DWITH_LIBWPG=$(usex wpg)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        find "${ED}" -type f -name "*.la" -delete || die
 
index b088e553b3f9cf6977ac0fb89b0c73e21fdd2e86..6226f7b5b65f4ab2658beb1ddfa10724f21b60bc 100644 (file)
@@ -6,7 +6,7 @@ EAPI=7
 PYTHON_COMPAT=( python3_{5,6,7} )
 PYTHON_REQ_USE="xml"
 MY_P="${P/_/}"
-inherit cmake-utils flag-o-matic xdg toolchain-funcs python-single-r1 git-r3
+inherit cmake flag-o-matic xdg toolchain-funcs python-single-r1 git-r3
 
 DESCRIPTION="SVG based generic vector-drawing program"
 HOMEPAGE="https://inkscape.org/"
@@ -108,7 +108,7 @@ pkg_pretend() {
 }
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
        sed -i "/install.*COPYING/d" CMakeScripts/ConfigCPack.cmake || die
 }
 
@@ -135,11 +135,11 @@ src_configure() {
                -DWITH_LIBWPG=$(usex wpg)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        find "${ED}" -type f -name "*.la" -delete || die
 
index 6d4b458a876541bd43e0a1cd2c0557842fd4db6e..0ba1f7bd1035cdb332bd0bf40268ba4f683d77dc 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils toolchain-funcs flag-o-matic xdg-utils
+inherit cmake toolchain-funcs flag-o-matic xdg-utils
 
 DESCRIPTION="Graphical user interface that provides a workflow for HDR imaging"
 HOMEPAGE="http://qtpfsgui.sourceforge.net https://github.com/LuminanceHDR/LuminanceHDR"
@@ -70,10 +70,10 @@ pkg_pretend() {
 
 src_configure() {
        local mycmakeargs=(
-               $(cmake-utils_use_find_package fits CFITSIO)
+               $(cmake_use_find_package fits CFITSIO)
                -DUSE_OPENMP="$(usex openmp)"
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 pkg_postinst() {
index e59d05f213b3c24587c49be90cd376258f0b4398..8af21b12f8201ec88568e6ed5ba08dca70e95dc8 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 MY_P=${P/_rc/-rc}
-inherit cmake-utils flag-o-matic toolchain-funcs xdg-utils
+inherit cmake flag-o-matic toolchain-funcs xdg-utils
 
 DESCRIPTION="A powerful cross-platform raw image processing program"
 HOMEPAGE="https://www.rawtherapee.com/"
@@ -58,7 +58,7 @@ src_configure() {
                -DCACHE_NAME_SUFFIX=""
                -DWITH_SYSTEM_KLT="off"
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 pkg_postinst() {
index 48b8dca754d137d98d68b71585cf30e610066cd1..b51ffe1ca52af9744d4e9754f6ac164cd1ff3601 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 MY_P=${P/_rc/-rc}
-inherit cmake-utils flag-o-matic toolchain-funcs xdg-utils
+inherit cmake flag-o-matic toolchain-funcs xdg-utils
 
 DESCRIPTION="A powerful cross-platform raw image processing program"
 HOMEPAGE="https://www.rawtherapee.com/"
@@ -58,7 +58,7 @@ src_configure() {
                -DCACHE_NAME_SUFFIX=""
                -DWITH_SYSTEM_KLT="off"
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 pkg_postinst() {
index 13b68abef36671b10b35529f2f853bd49889e70e..be247dca96bbd313b68f04efe939e6998a598026 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils desktop virtualx
+inherit cmake desktop virtualx
 
 DESCRIPTION="Interactive post-processing tool for scanned pages"
 HOMEPAGE="http://scantailor.org/ https://github.com/4lex4/scantailor-advanced"
@@ -37,11 +37,11 @@ PATCHES=( "${FILESDIR}"/${P}-tests.patch )
 
 src_test() {
        cd "${CMAKE_BUILD_DIR}" || die
-       virtx cmake-utils_src_test
+       virtx cmake_src_test
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        newicon resources/appicon.svg ${PN}.svg
        make_desktop_entry ${PN} "Scan Tailor Advanced"
index 0d2427edfda0647cce15450bf4ee22a72b029fad..0a5c2ae4ad1ae139526b3f6a8d986e7e3312274b 100644 (file)
@@ -3,9 +3,9 @@
 
 EAPI=7
 
-inherit cmake-multilib
-
+CMAKE_ECLASS=cmake
 MYP=RELEASE_${PV//./_}
+inherit cmake-multilib
 
 DESCRIPTION="C/C++ library for PDF generation"
 HOMEPAGE="http://www.libharu.org/"
@@ -36,5 +36,5 @@ multilib_src_configure() {
                -DLIBHPDF_EXAMPLES=NO # Doesn't work
                -DLIBHPDF_STATIC=NO
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index 2371b0b89b5dc3b846d52bc9d087ff40c648b742..57630393fa948e88a1fd92faf9cc2aff2c976f5f 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+CMAKE_ECLASS=cmake
 inherit cmake-multilib java-pkg-opt-2 libtool toolchain-funcs
 
 DESCRIPTION="MMX, SSE, and SSE2 SIMD accelerated JPEG library"
@@ -37,7 +38,7 @@ MULTILIB_WRAPPED_HEADERS=( /usr/include/jconfig.h )
 src_prepare() {
        default
 
-       cmake-utils_src_prepare
+       cmake_src_prepare
        java-pkg-opt-2_src_prepare
 }
 
@@ -54,11 +55,11 @@ multilib_src_configure() {
                -DWITH_MEM_SRCDST=ON
        )
        [[ ${ABI} == "x32" ]] && mycmakeargs+=( -DREQUIRE_SIMD=OFF ) #420239
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 multilib_src_compile() {
-       cmake-utils_src_compile
+       cmake_src_compile
 
        if multilib_is_native_abi ; then
                pushd "${WORKDIR}/debian/extra" &>/dev/null || die
@@ -68,7 +69,7 @@ multilib_src_compile() {
 }
 
 multilib_src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        if multilib_is_native_abi ; then
                pushd "${WORKDIR}/debian/extra" &>/dev/null || die
index df5ac185621fc296ba819f1a56ff99b533a8fb26..4b6cff224e4ee5081ed8b559393bace41ec4e3b0 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
 
-inherit cmake-utils flag-o-matic python-single-r1
+inherit cmake flag-o-matic python-single-r1
 
 DESCRIPTION="A color management framework for visual effects and animation"
 HOMEPAGE="http://opencolorio.org/"
@@ -57,7 +57,7 @@ pkg_setup() {
 }
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        use python && python_fix_shebang .
 }
@@ -84,8 +84,7 @@ src_configure() {
                -DOCIO_BUILD_PYGLUE=$(usex python)
                -DOCIO_USE_SSE=$(usex cpu_flags_x86_sse2)
                -DOCIO_BUILD_TESTS=$(usex test)
-               -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
                -DCMAKE_DISABLE_FIND_PACKAGE_LATEX=ON # They don't build
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index 0ce713b21a93db85f079d28e346a3c365b8aa552..300337e4729666dfc57a1f7e78001ec7c5641f6c 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
 
 DESCRIPTION="A library for reading and writing images"
 HOMEPAGE="https://sites.google.com/site/openimageio/ https://github.com/OpenImageIO"
@@ -81,7 +81,7 @@ pkg_setup() {
 }
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
        cmake_comment_add_subdirectory src/fonts
 }
 
@@ -121,5 +121,5 @@ src_configure() {
                -DUSE_SIMD=$(local IFS=','; echo "${mysimd[*]}")
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index ff710267180c1f32cbfe0974645d7357048e40e8..28d53f909b253c567a71ba645fc3d188dfc8b17f 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+CMAKE_ECLASS=cmake
 inherit cmake-multilib
 
 # Make sure that test data are not newer than release;
@@ -41,7 +42,7 @@ src_prepare() {
                        die "Failed to rename test data"
        fi
 
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
 
 multilib_src_configure() {
@@ -53,7 +54,7 @@ multilib_src_configure() {
                -DBUILD_STATIC_LIBS=$(usex static-libs)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 multilib_src_test() {