app-admin/sysstat: Version bump.
authorJeroen Roovers <jer@gentoo.org>
Wed, 26 Aug 2015 04:31:43 +0000 (06:31 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 26 Aug 2015 04:31:43 +0000 (06:31 +0200)
Package-Manager: portage-2.2.20.1

app-admin/sysstat/Manifest
app-admin/sysstat/sysstat-11.0.6.ebuild [new file with mode: 0644]
app-admin/sysstat/sysstat-11.1.6.ebuild [new file with mode: 0644]

index 427570f29f7859c1e88b82378c54806beb820222..36ff0c6f2318e38c5ecbc9bc8b9fc6617aa8a132 100644 (file)
@@ -1,3 +1,5 @@
 DIST sysstat-11.0.2.tar.xz 291256 SHA256 acd87fdfbe7c796480f14fc26119d8f785d26827d74a0f5bced6c492a91f1b96 SHA512 4bb5f2ee14346d83c59bd4da36ae8fc6c13197eabb808b1b5db84b593f07d8b366b1f6329abed8d43e2a8497a89de0f89a398b741d4ca23b4a3a95973b5f0f54 WHIRLPOOL 98daee288e22f803f19bbe423eb999f527e8997f2ffd3fe1fe784363260365ee833dd33b755f44d6bfcc685f70b47cb8fd70fdd9a3fa679829c1e608bd65f8e2
 DIST sysstat-11.0.5.tar.xz 294020 SHA256 6b165d1664d192a897d0b53ae6db9b279048ed377ed23765d0d4a1b4d21386d6 SHA512 cac99950ffdf04eac18f4d0e9ac14ceac2d57938231dbdbfd1f980b7c656bee8991d96d560595034da874955dc06b207d8041f0a6414b8fd51ee79d859f0ed73 WHIRLPOOL 4debcc810c87663794292cf6c7ba89aa7ee1139019c7e81c69b5f6bd2ae0c195a848e0c87c4baf3182fdfefc40003aac607a022e689b765c3ea7b5d1731015bd
+DIST sysstat-11.0.6.tar.xz 304516 SHA256 596a375bce1830514e26dd6c47ff366ec3113c637765a33f8924b43f97a16b49 SHA512 68f14790d535499ab8b116b77e812730eda003f9d11dd68b5089b284611a928679b538ecd5f139fe72cd737b27eaa972d386e7f81e0e5c4aaa27eae111196bcb WHIRLPOOL 2312c1198910bd1b89e6f87ff3cc0d350e3d84dde375a527b6d5895fe05a3f95c584a8999bdcc87556632d9d903a16adb0b0f58b53aedf2466aa62dd8554f7e0
 DIST sysstat-11.1.5.tar.xz 312436 SHA256 feb3a90d86ffd69cf5b88144a8876ae05bd42384f559676f08100671589fa2bb SHA512 07d4570628cd565f2a7d8f6f3631d9581e5f0c6866af2d1ba56ac2f2484541701e12b6c736631611f2588ba81638ad0a9860d6c4f5edc43296dc7200fac87cca WHIRLPOOL bf3da3b2722267d5980a8ddede370542f149e47eaf70dcbd82f7f300b8e6428e566efdc6f76d9474af9404d885780818a9270d76c725b06a713e0930182a8d33
+DIST sysstat-11.1.6.tar.xz 318752 SHA256 e1792aaae343e9c29d962b453e6eab2b3269474bfac2c8e1df463735e706595f SHA512 670cc25400459532721cb2cbcfb9a57612811ea261a888d37e8fe87755556bc2c37bb0ebd7f3c8c5e1d11bfa08c7b20bad77795b6f7c9ce90a8185b4eb3f541c WHIRLPOOL f30291a1e4b1affa382067f688c4c1af5a5fe5a5d20d5580be5bb6e5b2f67cf9eb2018ec672f50396a1c326b0c607994e4c874eb6e2477edc6b6224bb088bff4
diff --git a/app-admin/sysstat/sysstat-11.0.6.ebuild b/app-admin/sysstat/sysstat-11.0.6.ebuild
new file mode 100644 (file)
index 0000000..afcb078
--- /dev/null
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib systemd toolchain-funcs
+
+DESCRIPTION="System performance tools for Linux"
+HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
+SRC_URI="${HOMEPAGE}${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug +doc isag nls lm_sensors selinux"
+
+CDEPEND="
+       isag? (
+               dev-lang/tk:0
+               dev-vcs/rcs
+               sci-visualization/gnuplot
+       )
+       nls? ( virtual/libintl )
+       lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="
+       ${CDEPEND}
+       nls? ( sys-devel/gettext )
+"
+RDEPEND="
+       ${CDEPEND}
+       selinux? ( sec-policy/selinux-sysstat )
+"
+
+SYSSTAT_FAKE_RC_DIR=Gentoo-does-not-use-rc.d
+
+src_prepare() {
+       if use nls; then
+               strip-linguas -i nls/
+               local lingua pofile
+               for pofile in nls/*.po; do
+                       lingua=${pofile/nls\/}
+                       lingua=${lingua/.po}
+                       if ! has ${lingua} ${LINGUAS}; then
+                               rm "nls/${lingua}.po" || die
+                       fi
+               done
+       fi
+       epatch \
+               "${FILESDIR}"/${PN}-10.0.4-flags.patch \
+               "${FILESDIR}"/${PN}-11.0.4-cron.patch
+}
+
+src_configure() {
+       tc-export AR
+       sa_lib_dir=/usr/$(get_libdir)/sa \
+               conf_dir=/etc \
+               rcdir=${SYSSTAT_FAKE_RC_DIR} \
+               econf \
+                       --enable-copy-only \
+                       --with-systemdsystemunitdir=$(systemd_get_unitdir) \
+                       $(use_enable debug debuginfo) \
+                       $(use_enable doc documentation ) \
+                       $(use_enable isag install-isag) \
+                       $(use_enable lm_sensors sensors) \
+                       $(use_enable nls) \
+                       --enable-install-cron
+}
+
+src_compile() {
+       emake LFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+       keepdir /var/log/sa
+
+       emake \
+               DESTDIR="${D}" \
+               DOC_DIR=/usr/share/doc/${PF} \
+               install
+
+       dodoc contrib/sargraph/sargraph
+
+       rm -r "${D}/${SYSSTAT_FAKE_RC_DIR}" || die
+       newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+       systemd_dounit ${PN}.service
+
+       use doc && rm -f "${D}"usr/share/doc/${PF}/COPYING
+}
diff --git a/app-admin/sysstat/sysstat-11.1.6.ebuild b/app-admin/sysstat/sysstat-11.1.6.ebuild
new file mode 100644 (file)
index 0000000..5737c36
--- /dev/null
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib systemd toolchain-funcs
+
+DESCRIPTION="System performance tools for Linux"
+HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
+SRC_URI="${HOMEPAGE}${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +doc isag nls lm_sensors selinux"
+
+CDEPEND="
+       isag? (
+               dev-lang/tk:0
+               dev-vcs/rcs
+               sci-visualization/gnuplot
+       )
+       nls? ( virtual/libintl )
+       lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="
+       ${CDEPEND}
+       nls? ( sys-devel/gettext )
+"
+RDEPEND="
+       ${CDEPEND}
+       selinux? ( sec-policy/selinux-sysstat )
+"
+
+SYSSTAT_FAKE_RC_DIR=Gentoo-does-not-use-rc.d
+
+src_prepare() {
+       if use nls; then
+               strip-linguas -i nls/
+               local lingua pofile
+               for pofile in nls/*.po; do
+                       lingua=${pofile/nls\/}
+                       lingua=${lingua/.po}
+                       if ! has ${lingua} ${LINGUAS}; then
+                               rm "nls/${lingua}.po" || die
+                       fi
+               done
+       fi
+       epatch \
+               "${FILESDIR}"/${PN}-10.0.4-flags.patch \
+               "${FILESDIR}"/${PN}-11.0.4-cron.patch
+}
+
+src_configure() {
+       tc-export AR
+       sa_lib_dir=/usr/$(get_libdir)/sa \
+               conf_dir=/etc \
+               rcdir=${SYSSTAT_FAKE_RC_DIR} \
+               econf \
+                       --enable-copy-only \
+                       --with-systemdsystemunitdir=$(systemd_get_unitdir) \
+                       $(use_enable debug debuginfo) \
+                       $(use_enable doc documentation ) \
+                       $(use_enable isag install-isag) \
+                       $(use_enable lm_sensors sensors) \
+                       $(use_enable nls) \
+                       --enable-install-cron
+}
+
+src_compile() {
+       emake LFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+       keepdir /var/log/sa
+
+       emake \
+               DESTDIR="${D}" \
+               DOC_DIR=/usr/share/doc/${PF} \
+               install
+
+       dodoc contrib/sargraph/sargraph
+
+       rm -r "${D}/${SYSSTAT_FAKE_RC_DIR}" || die
+       newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+       systemd_dounit ${PN}.service
+
+       use doc && rm -f "${D}"usr/share/doc/${PF}/COPYING
+}