dev-python/fasteners: Replace virts with cond deps
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:03:11 +0000 (22:03 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:09:37 +0000 (22:09 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/fasteners/fasteners-0.14.1-r1.ebuild

index cf34846d9a38ada78ba1e56b78968fbc5f4e3ce8..8f021a8b24c297e325f478e37233f030fe464c27 100644 (file)
@@ -25,7 +25,10 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
                ${RDEPEND}
                dev-python/nose[${PYTHON_USEDEP}]
                dev-python/testtools[${PYTHON_USEDEP}]
-               virtual/python-futures[${PYTHON_USEDEP}] )"
+               $(python_gen_cond_dep '
+                       dev-python/futures[${PYTHON_USEDEP}]
+               ' -2)
+       )"
 
 python_test() {
        nosetests -v || die