dev-java/jlfgr: EAPI 5 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 6 Mar 2016 17:12:01 +0000 (17:12 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 6 Mar 2016 20:38:06 +0000 (20:38 +0000)
Package-Manager: portage-2.2.26

dev-java/jlfgr/jlfgr-1.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-java/jlfgr/jlfgr-1.0-r2.ebuild b/dev-java/jlfgr/jlfgr-1.0-r2.ebuild
new file mode 100644 (file)
index 0000000..b346291
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator java-pkg-2
+
+MY_PV=$(replace_all_version_separators '_')
+
+DESCRIPTION="Java(TM) Look and Feel Graphics Repository"
+HOMEPAGE="http://java.sun.com/developer/techDocs/hi/repository/"
+SRC_URI="mirror://gentoo/jlfgr-${MY_PV}.zip"
+
+LICENSE="sun-jlfgr"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+# Empty src_compile() to prevent message about not found build.xml
+src_compile() { :; }
+
+src_install() {
+       java-pkg_newjar "jlfgr-${MY_PV}.jar" "${PN}.jar"
+}