dev-util/valgrind: Fix test suite build failure on ppc
authorMatt Turner <mattst88@gentoo.org>
Mon, 4 Nov 2019 17:37:34 +0000 (09:37 -0800)
committerMatt Turner <mattst88@gentoo.org>
Mon, 4 Nov 2019 17:39:10 +0000 (09:39 -0800)
Closes: https://bugs.gentoo.org/685070
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-util/valgrind/files/valgrind-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch [new file with mode: 0644]
dev-util/valgrind/valgrind-3.15.0.ebuild
dev-util/valgrind/valgrind-9999.ebuild

diff --git a/dev-util/valgrind/files/valgrind-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch b/dev-util/valgrind/files/valgrind-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
new file mode 100644 (file)
index 0000000..4417665
--- /dev/null
@@ -0,0 +1,22 @@
+From beab8d9f8d65230567270331017184c8762faa42 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Mon, 4 Nov 2019 09:12:16 -0800
+Subject: [PATCH] Build ldst_multiple test with -fno-pie
+
+Bug: https://bugs.gentoo.org/685070
+---
+ none/tests/ppc32/Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/none/tests/ppc32/Makefile.am b/none/tests/ppc32/Makefile.am
+index 11697c99a..222efd3f2 100644
+--- a/none/tests/ppc32/Makefile.am
++++ b/none/tests/ppc32/Makefile.am
+@@ -156,3 +156,4 @@ test_isa_2_07_part2_LDADD = -lm
+ test_tm_LDADD = -lm
+ test_touch_tm_LDADD = -lm
++ldst_multiple_CFLAGS = $(AM_CFLAGS) -fno-pie
+-- 
+2.23.0
+
index b18a128859a5823750442fa1f57e6313fa77f626..d252d9dcee4c1cc1941600a5b3ea28bed1ac40d0 100644 (file)
@@ -31,6 +31,8 @@ src_prepare() {
        # Respect CFLAGS, LDFLAGS
        eapply "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
 
+       eapply "${FILESDIR}"/${PN}-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
+
        if [[ ${CHOST} == *-solaris* ]] ; then
                # upstream doesn't support this, but we don't build with
                # Sun/Oracle ld, we have a GNU toolchain, so get some things
index b7152e95dc5e587b209d6563da06f07db6e71e1f..41689a1904e1ef853377bbcfd0da4a8121f87667 100644 (file)
@@ -31,6 +31,8 @@ src_prepare() {
        # Respect CFLAGS, LDFLAGS
        eapply "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
 
+       eapply "${FILESDIR}"/${PN}-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
+
        if [[ ${CHOST} == *-solaris* ]] ; then
                # upstream doesn't support this, but we don't build with
                # Sun/Oracle ld, we have a GNU toolchain, so get some things