dev-lang/rust-bin: version bump
authorJauhien Piatlicki <jauhien@gentoo.org>
Sun, 27 Sep 2015 18:09:20 +0000 (20:09 +0200)
committerJauhien Piatlicki <jauhien@gentoo.org>
Sun, 27 Sep 2015 18:10:24 +0000 (20:10 +0200)
Package-Manager: portage-2.2.20.1

dev-lang/rust-bin/Manifest
dev-lang/rust-bin/rust-bin-1.3.0.ebuild [new file with mode: 0644]

index fa8ef05e1a332837a6fa4b8eaae433828c2bf2be..db670bf0517925df9e07a184a7b088bb86e713cb 100644 (file)
@@ -1,2 +1,4 @@
 DIST rustc-1.2.0-i686-unknown-linux-gnu.tar.gz 89840371 SHA256 f4c1692479314d63ee67914ec2065778c39ca4912f191a7894caf5264802b4fa SHA512 c89e6fac05c79755db7c15a275ac2a11d781fda10f6851ff13f0dce314f9a373bd5b79d0e1da0780071ce959693d4f08c33e3d18abbabe802922679d1e25a6b6 WHIRLPOOL 56c0636ecdc745fcdb41b77037486ba04c11b6a08568a0ada962687ead31bbd2c8f360894e629428fde4e5e3204d355e402d4a3651c4b13d0422e16beaec9f60
 DIST rustc-1.2.0-x86_64-unknown-linux-gnu.tar.gz 88888977 SHA256 32fb262ba9da26a6d5ad9b2ca420fb56d97af8f86acb5cda2e85b7e7c33f6dcc SHA512 ea87a2c0e05d3f7e7c738320fd08b53055f76703526846b87b885e7abbd320b2f393b9328daa1ca04e9cb545e906c5750b6dcede2ede23323aeab8a8b096ccfd WHIRLPOOL e82ed578218ce19b4a7ca5b9d4c842c5546b5daa6aa3be162393fc0ca7148cf245bb7a79719b10ea7bf43952f8908a6355eea9070f027fcd5f1d70caa37c9931
+DIST rustc-1.3.0-i686-unknown-linux-gnu.tar.gz 90445379 SHA256 7a3add3d229047bc68b929ba7b5f5d5796333f29e160c18c2a0ff24f643fab6b SHA512 afd001c1c285f12c13c0a9ecf0788f47ab72f069c1e1c5ec568973691ef2223c075fb99324e8245012e8a21003ea4fc63d874de99b95065aa9d09081798e09d5 WHIRLPOOL d273387d6eea540bf3a4bff96b5f754537ed265348661d412d37280f6d89fc726ed46fa03995b26eb444ac18e6c41f07d23c3c6844c7aaa00d2cc3970bad2f40
+DIST rustc-1.3.0-x86_64-unknown-linux-gnu.tar.gz 89444657 SHA256 eb243288615471a35106a9a384abd2888f1c0b9ee80ccff2c1bc034dd58b8b11 SHA512 7cc217fe2d1d58289f2e94c67c57506fd5fe7d85ed62e39daf11352c0887e87c12cb986b1de3bff07034da39784ef0f3901520ab28f34458dff7a6377f1c53b4 WHIRLPOOL 4cf1ef5473309dd23a6560368ed11ed9eb197a4f375fb4a4ec2904d06a4953341f58737766192dd30d35daf22e261dabed24a740d50585bb0714d6df45805a01
diff --git a/dev-lang/rust-bin/rust-bin-1.3.0.ebuild b/dev-lang/rust-bin/rust-bin-1.3.0.ebuild
new file mode 100644 (file)
index 0000000..409a1b9
--- /dev/null
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils bash-completion-r1
+
+MY_P="rustc-${PV}"
+
+DESCRIPTION="Systems programming language from Mozilla"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="amd64? ( http://static.rust-lang.org/dist/${MY_P}-x86_64-unknown-linux-gnu.tar.gz )
+       x86? ( http://static.rust-lang.org/dist/${MY_P}-i686-unknown-linux-gnu.tar.gz )"
+
+LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
+SLOT="stable"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
+       !dev-lang/rust:0
+"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+       default
+
+       local postfix
+       use amd64 && postfix=x86_64-unknown-linux-gnu
+       use x86 && postfix=i686-unknown-linux-gnu
+       mv "${WORKDIR}/${MY_P}-${postfix}" "${S}" || die
+}
+
+src_install() {
+       local components=rustc
+       ./install.sh \
+               --components="${components}" \
+               --disable-verify \
+               --prefix="${D}/opt/${P}" \
+               --mandir="${D}/usr/share/${P}/man" \
+               --disable-ldconfig \
+               || die
+
+       local rustc=rustc-bin-${PV}
+       local rustdoc=rustdoc-bin-${PV}
+       local rustgdb=rust-gdb-bin-${PV}
+
+       mv "${D}/opt/${P}/bin/rustc" "${D}/opt/${P}/bin/${rustc}" || die
+       mv "${D}/opt/${P}/bin/rustdoc" "${D}/opt/${P}/bin/${rustdoc}" || die
+       mv "${D}/opt/${P}/bin/rust-gdb" "${D}/opt/${P}/bin/${rustgdb}" || die
+
+       dosym "/opt/${P}/bin/${rustc}" "/usr/bin/${rustc}"
+       dosym "/opt/${P}/bin/${rustdoc}" "/usr/bin/${rustdoc}"
+       dosym "/opt/${P}/bin/${rustgdb}" "/usr/bin/${rustgdb}"
+
+       cat <<-EOF > "${T}"/50${P}
+       LDPATH="/opt/${P}/lib"
+       MANPATH="/usr/share/${P}/man"
+       EOF
+       doenvd "${T}"/50${P}
+
+       cat <<-EOF > "${T}/provider-${P}"
+       /usr/bin/rustdoc
+       /usr/bin/rust-gdb
+       EOF
+       dodir /etc/env.d/rust
+       insinto /etc/env.d/rust
+       doins "${T}/provider-${P}"
+}
+
+pkg_postinst() {
+       eselect rust update --if-unset
+
+       elog "Rust installs a helper script for calling GDB now,"
+       elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV},"
+
+       if has_version app-editors/emacs || has_version app-editors/emacs-vcs; then
+               elog "install app-emacs/rust-mode to get emacs support for rust."
+       fi
+
+       if has_version app-editors/gvim || has_version app-editors/vim; then
+               elog "install app-vim/rust-mode to get vim support for rust."
+       fi
+
+       if has_version 'app-shells/zsh'; then
+               elog "install app-shells/rust-zshcomp to get zsh completion for rust."
+       fi
+}
+
+pkg_postrm() {
+       eselect rust unset --if-invalid
+}