dev-java/osgi-core-api: EAPI 5 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Thu, 3 Dec 2015 17:13:27 +0000 (17:13 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Thu, 3 Dec 2015 21:19:06 +0000 (21:19 +0000)
Package-Manager: portage-2.2.20.1
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/osgi-core-api/osgi-core-api-5.0.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/osgi-core-api/osgi-core-api-5.0.0-r1.ebuild b/dev-java/osgi-core-api/osgi-core-api-5.0.0-r1.ebuild
new file mode 100644 (file)
index 0000000..30ac8b1
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="OSGi Service Platform Core API (Companion Code)"
+HOMEPAGE="http://www.osgi.org/Specifications/HomePage"
+SRC_URI="http://www.osgi.org/download/r5/osgi.core-${PV}.jar"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=virtual/jre-1.6"
+
+DEPEND="
+       >=virtual/jdk-1.6
+       app-arch/unzip"
+
+JAVA_SRC_DIR="OSGI-OPT/src"
+
+java_prepare() {
+       rm -r org || die
+}