Fix *initd, *confd and *envd calls (#173884, #174266)
authorTorsten Veller <tove@gentoo.org>
Sun, 29 Apr 2007 18:17:06 +0000 (18:17 +0000)
committerTorsten Veller <tove@gentoo.org>
Sun, 29 Apr 2007 18:17:06 +0000 (18:17 +0000)
Package-Manager: portage-2.1.2.5

net-dns/mydns/ChangeLog
net-dns/mydns/mydns-1.1.0.ebuild
net-dns/posadis/ChangeLog
net-dns/posadis/posadis-0.60.6.ebuild

index 8c1d8d2ab311ad62efd9ac97d3ddb329360bc3ef..3ad80d6efd2008d12c5462d70f9e94ec5df81f4a 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for net-dns/mydns
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/ChangeLog,v 1.22 2007/03/01 12:45:59 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/ChangeLog,v 1.23 2007/04/29 18:15:14 tove Exp $
+
+  29 Apr 2007; Torsten Veller <tove@gentoo.org> mydns-1.1.0.ebuild:
+  Fix *initd, *confd and *envd calls (#173884, #174266)
 
   01 Mar 2007; MATSUU Takuto <matsuu@gentoo.org> mydns-1.1.0.ebuild:
   Removed mysql USE flag, bug #168179.
index 7b480755cb8ed9af0d13359bc13b56bff9759099..98a0ea64ec43b0a08fa37469133bad272bd8dc05 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/mydns-1.1.0.ebuild,v 1.8 2007/03/01 12:45:59 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/mydns-1.1.0.ebuild,v 1.9 2007/04/29 18:15:14 tove Exp $
 
 inherit eutils
 
@@ -55,13 +55,13 @@ src_install() {
 
        dodoc AUTHORS BUGS ChangeLog NEWS README TODO
 
-       exeinto /etc/init.d; newexe ${FILESDIR}/mydns.rc6 mydns || die
+       newinitd "${FILESDIR}"/mydns.rc6 mydns || die
 
        if ! use postgres; then
-               sed -i -e 's/__db__/mysql/g' ${D}/etc/init.d/mydns || die
+               sed -i -e 's/__db__/mysql/g' "${D}"/etc/init.d/mydns || die
                dodoc QUICKSTART.mysql README.mysql
        else
-               sed -i -e 's/__db__/postgresql/g' ${D}/etc/init.d/mydns || die
+               sed -i -e 's/__db__/postgresql/g' "${D}"/etc/init.d/mydns || die
                dodoc QUICKSTART.postgres
        fi
 }
index 48db58b1cd763d4cddc7f3a1dbb2eb5e3c68e3a9..0132b5e48397a373b9571fa87c3f02578a2183ff 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for net-dns/posadis
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/posadis/ChangeLog,v 1.19 2006/12/14 23:03:43 blubb Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/posadis/ChangeLog,v 1.20 2007/04/29 18:17:06 tove Exp $
+
+  29 Apr 2007; Torsten Veller <tove@gentoo.org> posadis-0.60.6.ebuild:
+  Fix *initd, *confd and *envd calls (#173884, #174266)
 
   14 Dec 2006; Simon Stelling <blubb@gentoo.org> posadis-0.60.6.ebuild:
   multilib-strict fix; bug 153978
index bf618c6344f1edd5db6eb72115ce3ee28637fafb..ec6eaf14a31c12addbc9ba586af153f196a77a27 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/posadis/posadis-0.60.6.ebuild,v 1.6 2006/12/14 23:03:43 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/posadis/posadis-0.60.6.ebuild,v 1.7 2007/04/29 18:17:06 tove Exp $
 
 inherit libtool eutils multilib autotools
 
@@ -44,7 +44,7 @@ src_install() {
        keepdir /var/posadis
        keepdir /etc/posadis
 
-       exeinto /etc/init.d; newexe ${FILESDIR}/${PN}-init posadis
+       newinitd ${FILESDIR}/${PN}-init posadis
        insinto /etc/
        doins posadisrc