sci-biology/bcftools: fix PYTHON_COMPAT, add missing matplotlib dep
authorMartin Mokrejs <mmokrejs@gmail.com>
Fri, 7 Feb 2020 09:42:34 +0000 (10:42 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 7 Feb 2020 09:42:34 +0000 (10:42 +0100)
From NEWS one can infer bcftools was at least from about 1.7 version
python3 compatible. Moreover, at the moment the shenbang lines specifically
call python3.6. So, adjust the PYTHON_COMPAT accordingly. matplotlib is
used by the python scripts, unconditionally.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Closes: https://github.com/gentoo/gentoo/pull/14421
Signed-off-by: Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
Signed-off-by: David Seifert <soap@gentoo.org>
sci-biology/bcftools/bcftools-1.9-r1.ebuild [moved from sci-biology/bcftools/bcftools-1.9.ebuild with 84% similarity]
sci-biology/bcftools/files/bcftools-1.9-buildsystem.patch [new file with mode: 0644]

similarity index 84%
rename from sci-biology/bcftools/bcftools-1.9.ebuild
rename to sci-biology/bcftools/bcftools-1.9-r1.ebuild
index 53e47bc01a81ba9c52ed5e48d8631f9c06048069..8141e6d22924cc904215b8904025b12c78006eb7 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_6 )
 
 inherit python-single-r1
 
@@ -14,18 +14,18 @@ SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="
        dev-lang/perl
+       dev-python/matplotlib[${PYTHON_USEDEP}]
        =sci-libs/htslib-${PV}*:=
        sys-libs/zlib:=
        ${PYTHON_DEPS}"
 DEPEND="${RDEPEND}"
 
 PATCHES=(
-       "${FILESDIR}"/${PN}-1.5-buildsystem.patch
+       "${FILESDIR}"/${PN}-1.9-buildsystem.patch
        "${FILESDIR}"/${PN}-1.9-fix-shebangs.patch
 )
 
diff --git a/sci-biology/bcftools/files/bcftools-1.9-buildsystem.patch b/sci-biology/bcftools/files/bcftools-1.9-buildsystem.patch
new file mode 100644 (file)
index 0000000..a0df4b9
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/Makefile
++++ b/Makefile
+@@ -282,7 +282,6 @@
+       $(INSTALL_PROGRAM) $(PROGRAMS) $(DESTDIR)$(bindir)
+       $(INSTALL_SCRIPT) $(MISC_SCRIPTS) $(DESTDIR)$(misc_bindir)
+       $(INSTALL_MAN) doc/bcftools.1 $(DESTDIR)$(man1dir)
+-      $(INSTALL_PROGRAM) plugins/*.so $(DESTDIR)$(plugindir)
+ clean: testclean clean-plugins
+       -rm -f gmon.out *.o *~ $(PROGRAMS) version.h plugins/*.so plugins/*.P