net-misc/cni-plugins: 0.8.4 bump
authorWilliam Hubbs <williamh@gentoo.org>
Sun, 19 Jan 2020 19:34:47 +0000 (13:34 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Sun, 19 Jan 2020 19:35:43 +0000 (13:35 -0600)
Signed-off-by: William Hubbs <williamh@gentoo.org>
net-misc/cni-plugins/Manifest
net-misc/cni-plugins/cni-plugins-0.8.4.ebuild [new file with mode: 0644]

index 0f37333e90896ac5ce702fe1ba587bf1f776ef2d..c06bb485bcdea469c53b71b9ea6608ba5a892b96 100644 (file)
@@ -1,2 +1,3 @@
 DIST cni-plugins-0.8.2.tar.gz 1997790 BLAKE2B a3c0196c589a3a77de100a87ca8d3eb952478190c78dc50bc7b65d6229ec33593fe77be4a8c5b593d9ea8bb806f9b8d04768bc52b689b006640cfa34c176a0a1 SHA512 383540232593c7ef8c28f83e660a58ae6dd2592c6d97a43c8fc1f046a3fa448911d4066ec0a6a7d7e770a1a2dceee7c31d742100b0871e07d691fe6bdffd42f9
 DIST cni-plugins-0.8.3.tar.gz 2001599 BLAKE2B e087814146c53d372af5b1cc47098f0060cb1528618d9848287592c0b442856114c711ea747efca4e8a79e9ee0b4285678a6e48e07d0698f1382c1e822a49451 SHA512 054479a73ddbfbdb2986ac202ae2da7a69ae7bb693a250885f950a26973c60be3053d4e95ca24cf5eb67c104b9af8231f859e22c01a066ce3a206a186fc55a6d
+DIST cni-plugins-0.8.4.tar.gz 2002863 BLAKE2B afc0229256f04b5079ff4f30fca422e7e72dc46b01a988b38647bbed767ad4c8362c99eca84ade86a52ffbd3aadda60ae1b14974436eab862d4c9ed356320b2b SHA512 1a66a9d2cc3bad17201426905ed8349fa0c260ffef423338bc93c4ff191c4d38e6b9228ca3b5c44b148c854379f741f2dbd88ac9937dc1599f95f4df8b6f4346
diff --git a/net-misc/cni-plugins/cni-plugins-0.8.4.ebuild b/net-misc/cni-plugins/cni-plugins-0.8.4.ebuild
new file mode 100644 (file)
index 0000000..82ab7c1
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info golang-vcs-snapshot
+
+DESCRIPTION="Standard networking plugins for container networking"
+HOMEPAGE="https://github.com/containernetworking/plugins"
+EGO_PN="github.com/containernetworking/plugins"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="hardened"
+
+CONFIG_CHECK="~BRIDGE_VLAN_FILTERING"
+
+src_compile() {
+       pushd src || die
+       local i
+       for i in plugins/{meta/{bandwidth,firewall,flannel,portmap,sbr,tuning},main/{bridge,host-device,ipvlan,loopback,macvlan,ptp,vlan},ipam/{dhcp,host-local,static},sample}; do
+               CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" GOPATH="${WORKDIR}/${P}" go install -v "${EGO_PN}/${i}" || die
+       done
+       popd || die
+}
+
+src_install() {
+       exeinto /opt/cni/bin
+       doexe bin/*
+       pushd src/${EGO_PN} || die
+       dodoc README.md
+       local i
+       for i in plugins/{meta/{bandwidth,firewall,flannel,portmap,sbr,tuning},main/{bridge,host-device,ipvlan,loopback,macvlan,ptp,vlan},ipam/{dhcp,host-local,static},sample}; do
+               newdoc README.md ${i##*/}.README.md
+       done
+       popd || die
+}