Fix broken autotools handling.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 14:36:47 +0000 (14:36 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 14:36:47 +0000 (14:36 +0000)
Package-Manager: portage-2.1.2_rc4-r5

dev-db/mysqlnavigator/ChangeLog
dev-db/mysqlnavigator/mysqlnavigator-1.4.2.ebuild
dev-db/unixODBC/ChangeLog
dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild

index b95dd5576f155b7c769642ff6a8fffcdbdefd92b..2e3d7dad853d1c30f32c3b684d24a7a5918af390 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-db/mysqlnavigator
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqlnavigator/ChangeLog,v 1.23 2006/11/23 20:00:20 vivo Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqlnavigator/ChangeLog,v 1.24 2007/01/04 14:35:01 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+  mysqlnavigator-1.4.2.ebuild:
+  Fix broken autotools handling.
 
   23 Nov 2006; Francesco Riosa <vivo@gentoo.org>
   mysqlnavigator-1.4.2.ebuild:
index 3bb151f93509630f9fa69a68379efa106ea51842..e41ae6d720ad098e2ba870a1c0266506aa10d024 100644 (file)
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqlnavigator/mysqlnavigator-1.4.2.ebuild,v 1.16 2006/11/23 20:00:20 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqlnavigator/mysqlnavigator-1.4.2.ebuild,v 1.17 2007/01/04 14:35:01 flameeyes Exp $
 
-inherit eutils qt3
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils qt3 autotools
 
 IUSE=""
 DESCRIPTION="Advanced Qt based front end to mysql"
@@ -34,11 +37,10 @@ src_unpack() {
        export CXXFLAGS="${CXXFLAGS} -DUSE_OLD_FUNCTIONS=1"
        sed "s|^CXXFLAGS=\".*\"$|CXXFLAGS=\"${CXXFLAGS}\"|g" <configure.in.orig >configure.in
        #force changes in
-       autoreconf
+       eautoreconf
 }
 
 src_compile() {
-       libtoolize --copy --force
        myconf="--with-mysql-includes=/usr/include/mysql"
        econf ${myconf} || die "econf failed"
        emake -DUSE_OLD_FUNCTIONS=1
index cf907781ee7980964efdb0771f6bf172b95e3371..3353a2b7670e5772e32d13be599193727bbafcec 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-db/unixODBC
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.61 2006/12/02 17:55:52 chtekk Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.62 2007/01/04 14:36:47 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+  unixODBC-2.2.11-r1.ebuild:
+  Fix broken autotools handling.
 
   02 Dec 2006; Luca Longinotti <chtekk@gentoo.org>
   unixODBC-2.2.11-r1.ebuild:
index a063772226b205d9958dfcf26a7d92e5faf15664..a50283ea6c578be16cd09df698f016f613d0d726 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild,v 1.17 2006/12/02 17:55:52 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild,v 1.18 2007/01/04 14:36:47 flameeyes Exp $
 
 WANT_AUTOCONF="latest"
 WANT_AUTOMAKE="latest"
@@ -31,11 +31,8 @@ src_unpack() {
        # braindead check in configure fails - hackish approach
        epatch "${FILESDIR}/${P}-configure.in.patch"
        epatch "${FILESDIR}/${P}-Makefile.am.patch"
-       autotools_set_versions
-       aclocal --force && \
-       libtoolize --copy --force && \
-       automake && \
-       autoconf || die "autotools failed"
+
+       eautoreconf
 }
 
 src_compile() {