dev-python/python-libevdev: Add package
authorMatt Turner <mattst88@gentoo.org>
Mon, 9 Mar 2020 01:20:58 +0000 (18:20 -0700)
committerMatt Turner <mattst88@gentoo.org>
Mon, 9 Mar 2020 02:05:41 +0000 (19:05 -0700)
Closes: https://bugs.gentoo.org/703804
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-python/python-libevdev/Manifest [new file with mode: 0644]
dev-python/python-libevdev/metadata.xml [new file with mode: 0644]
dev-python/python-libevdev/python-libevdev-0.8.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-libevdev/Manifest b/dev-python/python-libevdev/Manifest
new file mode 100644 (file)
index 0000000..7745204
--- /dev/null
@@ -0,0 +1 @@
+DIST python-libevdev-0.8.tar.bz2 30375 BLAKE2B b59a705d49a54d5f98bca3bdf97038128df35294d4e62ffe058021c4da846e75a372660a4beef7e83dbf5b16a4d7d9195547f713bd290b14ca28ecd9291ac641 SHA512 c3c35e82b78f8968c930883a99def348a012a05ea122ac24e757441e81079f7c12bd50d96e8cec7b799a2d775d834859f924e8d1dc5841c718c050287fd1beb0
diff --git a/dev-python/python-libevdev/metadata.xml b/dev-python/python-libevdev/metadata.xml
new file mode 100644 (file)
index 0000000..3e36bc0
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>x11@gentoo.org</email>
+    <name>X11</name>
+  </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-libevdev/python-libevdev-0.8.ebuild b/dev-python/python-libevdev/python-libevdev-0.8.ebuild
new file mode 100644 (file)
index 0000000..1dc82be
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrappers for the libevdev library"
+HOMEPAGE="https://gitlab.freedesktop.org/libevdev/python-libevdev"
+SRC_URI="https://gitlab.freedesktop.org/libevdev/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+python_test() {
+       esetup.py test
+}