dev-python/secretstorage: Skip gnome-keyring on hppa & sparc
authorMichał Górny <mgorny@gentoo.org>
Fri, 29 May 2020 15:38:30 +0000 (17:38 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 29 May 2020 15:38:46 +0000 (17:38 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/secretstorage/secretstorage-3.1.2.ebuild

index b00b292f5d911bee496e10fbf090670ca4fec636..a375fee0215703be150298c6a3a0b917eeecb32d 100644 (file)
@@ -23,16 +23,27 @@ RDEPEND="
        >=dev-python/jeepney-0.4.2[${PYTHON_USEDEP}]
 "
 BDEPEND="
-       test? (
+       test? ( !hppa? ( !sparc? (
                gnome-base/gnome-keyring
                sys-apps/dbus
-       )
+       ) ) )
 "
 
 distutils_enable_tests unittest
 distutils_enable_sphinx docs \
        dev-python/alabaster
 
+src_test() {
+       case ${ARCH} in
+               hppa|sparc)
+                       einfo "gnome-keyring is not supported on ${ARCH}, skipping tests"
+                       return
+                       ;;
+       esac
+
+       distutils-r1_src_test
+}
+
 python_test() {
        dbus-run-session "${EPYTHON}" -m unittest discover -v -s tests \
                || die "tests failed with ${EPYTHON}"