dev-libs/wl-clipboard: initial add
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 9 Feb 2019 01:30:12 +0000 (19:30 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 9 Feb 2019 02:22:56 +0000 (20:22 -0600)
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-libs/wl-clipboard/Manifest [new file with mode: 0644]
dev-libs/wl-clipboard/metadata.xml [new file with mode: 0644]
dev-libs/wl-clipboard/wl-clipboard-1.0.0.ebuild [new file with mode: 0644]
dev-libs/wl-clipboard/wl-clipboard-9999.ebuild [new file with mode: 0644]

diff --git a/dev-libs/wl-clipboard/Manifest b/dev-libs/wl-clipboard/Manifest
new file mode 100644 (file)
index 0000000..3c882e3
--- /dev/null
@@ -0,0 +1 @@
+DIST wl-clipboard-1.0.0.tar.gz 25442 BLAKE2B 02e2e99287e1376f26f73a546654e66ddb9d0a85caf457e4a023f0a02cb4d7a9cb3c8ab5840982bf014afb9fc3601722dd4c2fc4239b74a05d309a0a16d20299 SHA512 328c18a9eb2ccfc788e7ab785077ab8d663c75f2ce8f6f434799575fc76ccc89238faf930948bced216d22bee0adfc810af5e84ffc63bc82c4e1d02da4286296
diff --git a/dev-libs/wl-clipboard/metadata.xml b/dev-libs/wl-clipboard/metadata.xml
new file mode 100644 (file)
index 0000000..1c9838f
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <longdescription lang="en">
+               Two command-line Wayland clipboard utilities, wl-copy and wl-paste, that let you easily copy data between the clipboard and Unix pipes, sockets, files and so on.
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-libs/wl-clipboard/wl-clipboard-1.0.0.ebuild b/dev-libs/wl-clipboard/wl-clipboard-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..d7fcf53
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland clipboard utilities"
+HOMEPAGE="https://github.com/bugaevc/wl-clipboard"
+
+if [[ ${PV} == 9999 ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/bugaevc/${PN}.git"
+else
+       SRC_URI="https://github.com/bugaevc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND=""
diff --git a/dev-libs/wl-clipboard/wl-clipboard-9999.ebuild b/dev-libs/wl-clipboard/wl-clipboard-9999.ebuild
new file mode 100644 (file)
index 0000000..d7fcf53
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland clipboard utilities"
+HOMEPAGE="https://github.com/bugaevc/wl-clipboard"
+
+if [[ ${PV} == 9999 ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/bugaevc/${PN}.git"
+else
+       SRC_URI="https://github.com/bugaevc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND=""