dev-python/httplib2: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Thu, 4 Jan 2018 20:05:35 +0000 (21:05 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 4 Jan 2018 20:34:55 +0000 (21:34 +0100)
dev-python/httplib2/Manifest
dev-python/httplib2/files/python-httplib2-0.9-cve-2013-2037.patch [deleted file]
dev-python/httplib2/httplib2-0.10.3.ebuild [deleted file]
dev-python/httplib2/httplib2-0.9.2-r2.ebuild [deleted file]

index 3f7bddd40c38a3d1dc0cab8a1688e0836961e825..3e45a6dcbfd1ff14ad3c713de48470e17eb37dfc 100644 (file)
@@ -1,2 +1 @@
 DIST httplib2-0.10.3.tar.gz 204500 BLAKE2B f71d679b42865bd8e56f708e71d475bfc6988267b07cf7af298ae7ba2c132a67fa04f54f36dfa0d222f86f421ade40724638fdc5840f340da0e8e1a717bb6cdd SHA512 d024986ffd577858017d7a8cfcae98a6cd04b8c89634ea302df4c1443eb2381cecca6ffbb631c9d4260335a3462df6d5604ec485aa591a05cb0231a3f6745aaa
-DIST httplib2-0.9.2.tar.gz 205165 BLAKE2B 8bcd1b5786ef2bac51d31766f2477e05cb942feb5edc829ef8d13cd256169da3fb812880fe422e61c3c14d268833e38686452916b5cfc7e0ed1cff17bad6dcfb SHA512 cf1684f2d072588bc676c02491667480bdd2be0b3494703129d9cfa339d1233e14c0b4895b174d4c2ec5e2f5ae265d165b4e001b180f39f81db2178f91a032f8
diff --git a/dev-python/httplib2/files/python-httplib2-0.9-cve-2013-2037.patch b/dev-python/httplib2/files/python-httplib2-0.9-cve-2013-2037.patch
deleted file mode 100644 (file)
index 6a09337..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Nur httplib2-0.9.orig/python2/httplib2/__init__.py httplib2-0.9/python2/httplib2/__init__.py
---- httplib2-0.9.orig/python2/httplib2/__init__.py     2015-04-03 13:10:43.401035131 -0600
-+++ httplib2-0.9/python2/httplib2/__init__.py  2015-04-03 13:10:08.470685647 -0600
-@@ -1042,7 +1042,7 @@
-                         raise CertificateHostnameMismatch(
-                             'Server presented certificate that does not match '
-                             'host %s: %s' % (hostname, cert), hostname, cert)
--            except ssl_SSLError, e:
-+            except (ssl_SSLError, CertificateHostnameMismatch), e:
-                 if sock:
-                     sock.close()
-                 if self.sock:
-@@ -1052,7 +1052,7 @@
-                 # to get at more detailed error information, in particular
-                 # whether the error is due to certificate validation or
-                 # something else (such as SSL protocol mismatch).
--                if e.errno == ssl.SSL_ERROR_SSL:
-+                if hasattr(e, 'errno') and e.errno == ssl.SSL_ERROR_SSL:
-                     raise SSLHandshakeError(e)
-                 else:
-                     raise
diff --git a/dev-python/httplib2/httplib2-0.10.3.ebuild b/dev-python/httplib2/httplib2-0.10.3.ebuild
deleted file mode 100644 (file)
index a12c085..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A comprehensive HTTP client library"
-HOMEPAGE="https://pypi.python.org/pypi/httplib2 https://github.com/jcgregorio/httplib2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-# tests connect to random remote sites
-RESTRICT="test"
-
-python_prepare_all() {
-       chmod o+r */*egg*/* || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       if [[ ${EPYTHON} == python2.7 ]] ; then
-               cd python2 || die
-       else
-               cd python3 || die
-       fi
-
-       "${PYTHON}" httplib2test.py || die
-}
diff --git a/dev-python/httplib2/httplib2-0.9.2-r2.ebuild b/dev-python/httplib2/httplib2-0.9.2-r2.ebuild
deleted file mode 100644 (file)
index 063a762..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A comprehensive HTTP client library"
-HOMEPAGE="https://pypi.python.org/pypi/httplib2 https://github.com/jcgregorio/httplib2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-# tests connect to random remote sites
-RESTRICT="test"
-
-PATCHES=(
-       "${FILESDIR}/python-httplib2-0.9-cve-2013-2037.patch"
-)
-
-python_prepare_all() {
-       chmod o+r */*egg*/* || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       if [[ ${EPYTHON} == python2.7 ]] ; then
-               cd python2 || die
-       else
-               cd python3 || die
-       fi
-
-       "${PYTHON}" httplib2test.py || die
-}