dev-lang/rust: Disable system-llvm USE flag in 1.32.0 (bug #675752)
authorPatrick McLean <patrick.mclean@sony.com>
Fri, 18 Jan 2019 19:39:10 +0000 (11:39 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Fri, 18 Jan 2019 19:40:09 +0000 (11:40 -0800)
Add "!system-llvm" to REQUIRED_USE since 1.32.0 pulls in a git version
of llvm to fix the segfault.

Also bump the llvm dep to >=7 since 7 is required now.

Bug: https://bugs.gentoo.org/675752
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-lang/rust/rust-1.32.0.ebuild

index 8b125eb86e342b47a083812d9f6a0c2adc5d4741..6adfe7ff5b4e7260ef1e434fa34b3c4524db8ca4 100644 (file)
@@ -45,7 +45,7 @@ COMMON_DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
                net-libs/libssh2
                net-libs/http-parser:=
                net-misc/curl[ssl]
-               system-llvm? ( >=sys-devel/llvm-6:= )"
+               system-llvm? ( >=sys-devel/llvm-7:= )"
 DEPEND="${COMMON_DEPEND}
        ${PYTHON_DEPS}
        || (
@@ -59,6 +59,9 @@ RDEPEND="${COMMON_DEPEND}
 REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
                                x86? ( cpu_flags_x86_sse2 )"
 
+# bug #675752
+REQUIRED_USE+=" !system-llvm"
+
 S="${WORKDIR}/${MY_P}-src"
 
 PATCHES=( "${FILESDIR}"/1.30.1-clippy-sysroot.patch )