media-gfx/exiv2: remove vulnerable 0.26_p20180811-r3
authorMichael Palimaka <kensington@gentoo.org>
Mon, 11 Mar 2019 06:13:48 +0000 (17:13 +1100)
committerMichael Palimaka <kensington@gentoo.org>
Mon, 11 Mar 2019 06:14:00 +0000 (17:14 +1100)
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Michael Palimaka <kensington@gentoo.org>
media-gfx/exiv2/Manifest
media-gfx/exiv2/exiv2-0.26_p20180811-r3.ebuild [deleted file]
media-gfx/exiv2/files/exiv2-0.26-fix-docs.patch [deleted file]
media-gfx/exiv2/files/exiv2-0.26-tools-optional.patch [deleted file]

index b8b4960b6b23aa3d53c52279e53e22b07c9ec135..364b5bf76aa3fae830ae90c2d5b270b22e363152 100644 (file)
@@ -1,2 +1 @@
-DIST exiv2-0.26_p20180811d.tar.xz 1722216 BLAKE2B 9e1c8307eb923c340894c82c37e9f6c31d82ff1b1de3c79d4ec9b0ec9428ad1d05f945e9a4e440028335857e7fc32d50cdc5245842d743e017037bd641b654db SHA512 5453650888440028acb139a02b387eab0232551c97256ce88dd626fa4cc8800ec02ad66e093c314bbfdc60726995b6c8482572d1ffaec73a265209c98c901780
 DIST exiv2-0.27.0a-Source.tar.gz 27168207 BLAKE2B 3f5c4fbe4f41c1114c0a54433c810ed0fb28ae3fbe8258eb7a02da716b833d62a94725f839accf22600c420ace5cdbead599440d335ff694a4f123820613ecd9 SHA512 9873d6815c2a87b7cdc49e8863f72c713fe1054f2f46d2c9aaa7ca2cd42096a36c2970e6a396af9000faba32fa9ff054b9d2c5e22f3e2624669440e553239f9c
diff --git a/media-gfx/exiv2/exiv2-0.26_p20180811-r3.ebuild b/media-gfx/exiv2/exiv2-0.26_p20180811-r3.ebuild
deleted file mode 100644 (file)
index bce9baa..0000000
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit cmake-multilib python-any-r1
-
-DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
-HOMEPAGE="http://www.exiv2.org/"
-SRC_URI="https://dev.gentoo.org/~asturm/distfiles/${P}d.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0/26"
-KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
-IUSE="doc examples nls png webready xmp"
-
-RDEPEND="
-       >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
-       nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
-       png? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
-       webready? (
-               net-libs/libssh[${MULTILIB_USEDEP}]
-               net-misc/curl[${MULTILIB_USEDEP}]
-       )
-       xmp? ( >=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
-       doc? (
-               ${PYTHON_DEPS}
-               app-doc/doxygen
-               dev-libs/libxslt
-               media-gfx/graphviz
-               virtual/pkgconfig
-       )
-       nls? ( sys-devel/gettext )
-"
-
-DOCS=( README doc/ChangeLog doc/cmd.txt )
-
-PATCHES=(
-       # TODO: Take to upstream
-       "${FILESDIR}"/${PN}-0.26-fix-docs.patch
-       "${FILESDIR}"/${PN}-0.26-tools-optional.patch
-)
-
-pkg_setup() {
-       use doc && python-any-r1_pkg_setup
-}
-
-src_prepare() {
-       if [[ ${PV} != *9999 ]] ; then
-               if [[ -d po ]] ; then
-                       pushd po > /dev/null || die
-                       local lang
-                       for lang in *.po; do
-                               if [[ -e ${lang} ]] \
-                                               && ! has ${lang/.po/} ${LINGUAS-${lang/.po/}} ; then
-                                       case ${lang} in
-                                               CMakeLists.txt | \
-                                               ${PN}.pot)      ;;
-                                               *) rm -r ${lang} || die ;;
-                                       esac
-                               fi
-                       done
-                       popd > /dev/null || die
-               else
-                       die "Failed to prepare LINGUAS - po directory moved?"
-               fi
-       fi
-
-       # FIXME @upstream:
-       einfo "Converting doc/cmd.txt to UTF-8"
-       iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
-       mv -f doc/cmd.txt.tmp doc/cmd.txt || die
-
-       if use doc; then
-               einfo "Updating doxygen config"
-               doxygen &>/dev/null -u config/Doxyfile || die
-       fi
-
-       edos2unix samples/exiv2json.cpp # workaround for CVE-2017-18005 patch
-
-       cmake-utils_src_prepare
-}
-
-multilib_src_configure() {
-       local mycmakeargs=(
-               -DEXIV2_ENABLE_BUILD_SAMPLES=NO
-               -DEXIV2_ENABLE_BUILD_PO=$(usex nls)
-               -DEXIV2_ENABLE_NLS=$(usex nls)
-               -DEXIV2_ENABLE_PNG=$(usex png)
-               -DEXIV2_ENABLE_CURL=$(usex webready)
-               -DEXIV2_ENABLE_SSH=$(usex webready)
-               -DEXIV2_ENABLE_WEBREADY=$(usex webready)
-               -DEXIV2_ENABLE_XMP=$(usex xmp)
-               -DEXIV2_ENABLE_LIBXMP=NO
-               $(multilib_is_native_abi || echo -DEXIV2_ENABLE_TOOLS=NO)
-       )
-
-       cmake-utils_src_configure
-}
-
-multilib_src_compile() {
-       cmake-utils_src_compile
-
-       if multilib_is_native_abi; then
-               use doc && emake -j1 doc
-       fi
-}
-
-multilib_src_install_all() {
-       use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
-       use doc && HTML_DOCS=( "${S}"/doc/html/. )
-
-       einstalldocs
-       find "${D}" -name '*.la' -delete || die
-
-       if use examples; then
-               docinto examples
-               dodoc samples/*.cpp
-       fi
-}
diff --git a/media-gfx/exiv2/files/exiv2-0.26-fix-docs.patch b/media-gfx/exiv2/files/exiv2-0.26-fix-docs.patch
deleted file mode 100644 (file)
index 05ea18d..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
---- a/CMakeLists.txt   2015-07-19 16:04:35.363628707 +0200
-+++ b/CMakeLists.txt   2015-07-19 16:28:31.051680136 +0200
-@@ -216,9 +216,7 @@
- ADD_SUBDIRECTORY( xmpsdk )
- ADD_SUBDIRECTORY( src )
--IF( EXIV2_ENABLE_BUILD_SAMPLES )
--    ADD_SUBDIRECTORY( samples )
--ENDIF( EXIV2_ENABLE_BUILD_SAMPLES )
-+ADD_SUBDIRECTORY( samples )
- IF( EXIV2_ENABLE_BUILD_PO )
-     ADD_SUBDIRECTORY( po )
---- a/samples/CMakeLists.txt   2015-07-19 16:04:35.360628744 +0200
-+++ b/samples/CMakeLists.txt   2015-07-19 16:30:46.415987850 +0200
-@@ -21,6 +21,10 @@
- include_directories("${CMAKE_SOURCE_DIR}/include" "${CMAKE_SOURCE_DIR}/src")
--SET( SAMPLES addmoddel.cpp
-+SET( SAMPLES taglist.cpp )
-+
-+IF( EXIV2_ENABLE_BUILD_SAMPLES )
-+    SET( SAMPLES ${SAMPLES}
-+             addmoddel.cpp
-              convert-test.cpp
-              easyaccess-test.cpp
-              exifcomment.cpp
-@@ -38,7 +42,6 @@
-              mmap-test.cpp
-              prevtest.cpp
-              stringto-test.cpp
--             taglist.cpp
-              tiff-test.cpp
-              werror-test.cpp
-              write-test.cpp
-@@ -47,6 +50,7 @@
-              xmpparser-test.cpp
-              xmpsample.cpp
-    )
-+ENDIF()
- FOREACH(entry ${SAMPLES})
-     STRING( REPLACE ".cpp" "" target ${entry})
-@@ -63,6 +67,7 @@
-     SET( MC_SRC            ${MC_SRC}       ../src/getopt_win32.c )
- ENDIF( MSVC )
-+IF( EXIV2_ENABLE_BUILD_SAMPLES )
- SET( MC_SRC ${MC_SRC} metacopy.cpp ../src/utils.cpp )
- ADD_EXECUTABLE( metacopy ${MC_SRC} )
- TARGET_LINK_LIBRARIES( metacopy exiv2lib )
-@@ -79,6 +84,7 @@
- # ******************************************************************************
- # Man page
- INSTALL( FILES exiv2samples.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1 )
-+ENDIF()
- # That's all Folks!
- ##
---- a/doc/templates/Makefile   2015-07-19 16:50:50.589933604 +0200
-+++ b/doc/templates/Makefile   2015-07-19 16:51:07.686719864 +0200
-@@ -143,7 +143,7 @@
-          xmp_mwg-rs \
-          xmp_mwg-kw
--TAGLIST = ../../bin/taglist
-+TAGLIST = ../../src/bin/taglist
- # **********************************************************************
- # ======================================================================
-diff --git a/doc/cmake_doc.sh b/doc/cmake_doc.sh
-index 44dd6760..5910a86d 100755
---- a/doc/cmake_doc.sh
-+++ b/doc/cmake_doc.sh
-@@ -16,7 +16,7 @@ if [ $# == 1 ]; then
-         mv src/exv_conf.h.keep src/exv_conf.h
-     fi
-     mkdir -p  src/bin/
--    cp    -f  "${CMAKE_BINARY_DIR}/bin/taglist" src/bin/
-+    cp    -f  "${CMAKE_BINARY_DIR}/samples/taglist" src/bin/
-     make doc
- fi
diff --git a/media-gfx/exiv2/files/exiv2-0.26-tools-optional.patch b/media-gfx/exiv2/files/exiv2-0.26-tools-optional.patch
deleted file mode 100644 (file)
index 686b37f..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/CMakeLists.txt   2017-06-07 00:14:25.374608170 +0200
-+++ b/CMakeLists.txt   2017-06-07 00:17:00.680483299 +0200
-@@ -60,6 +60,7 @@
-     OPTION( EXIV2_ENABLE_SSH           "USE Libssh for SshIo"                              ON  )
-     SET ( EXIV2_ENABLE_DYNAMIC_RUNTIME OFF )
- ENDIF()
-+OPTION( EXIV2_ENABLE_TOOLS         "Build exiv2 executable"                                ON  )
- # set include path for FindXXX.cmake files
- set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/config/")
---- a/src/CMakeLists.txt       2017-06-07 00:14:25.368608098 +0200
-+++ b/src/CMakeLists.txt       2017-06-07 00:16:06.710831682 +0200
-@@ -317,10 +317,12 @@
- # ******************************************************************************
- # exiv2 application
--ADD_EXECUTABLE( exiv2 ${EXIV2_SRC}  ${EXIV2_HDR} )
-+IF(EXIV2_ENABLE_TOOLS)
-+    ADD_EXECUTABLE( exiv2 ${EXIV2_SRC}  ${EXIV2_HDR} )
- target_compile_definitions(exiv2 PRIVATE EXV_LOCALEDIR="${CMAKE_INSTALL_LOCALEDIR}" )
--TARGET_LINK_LIBRARIES( exiv2 exiv2lib ${LIBINTL_LIBRARIES} )
--INSTALL( TARGETS exiv2 RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
-+    TARGET_LINK_LIBRARIES( exiv2 exiv2lib ${LIBINTL_LIBRARIES} )
-+    INSTALL( TARGETS exiv2 RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
-+ENDIF( EXIV2_ENABLE_TOOLS )
- # ******************************************************************************
- # connection test application