net-analyzer/netdata: 1.22.1 version bump
authorCraig Andrews <candrews@gentoo.org>
Tue, 12 May 2020 19:58:42 +0000 (15:58 -0400)
committerCraig Andrews <candrews@gentoo.org>
Tue, 12 May 2020 20:00:24 +0000 (16:00 -0400)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Craig Andrews <candrews@gentoo.org>
net-analyzer/netdata/Manifest
net-analyzer/netdata/netdata-1.22.1.ebuild [new file with mode: 0644]

index cdb7f3a05f4cda9673089e845f08860f804cf715..63b902ed9f50f4b1636044ed18b95bc983231301 100644 (file)
@@ -1,2 +1,3 @@
 DIST netdata-1.21.1.tar.gz 3748090 BLAKE2B 5cc8dd47b768838eecc7c8af35a82548dc5bb16acb0a88c17ee1254f86ca9b63a5108bce9205c000283b817478749d963b69c65e3bdc8e2fadecc9a1826a7f2e SHA512 66d2e0cb977275250fd7b51e5156957a4506ddba586de5fe796459ea241cbbed7013fd4cf9d7acf6666407352fb34e3b962a2d01565a9cb982c89c76b7cd79b9
 DIST netdata-1.22.0.tar.gz 3786121 BLAKE2B ad34bcdb94cf44f8de154bf53b2e4ecbecee43c6cef2e5337c0fa6bd08b0feb41c25ee96e51fc6c54d72909559e5ac822b44153daa71255487bb0713ce6eca1d SHA512 3bf239c3e950195ef7b8b43f1c17f2cc94f9257a4f21665629f7b518cc6fcef3b0837743254efd03323408b39e2afa9533487147fa30c8f015705c391aa543f3
+DIST netdata-1.22.1.tar.gz 3787203 BLAKE2B cb09ade9540d81fac9b30738650206bce263b74445ce76bf3e9c57a7935bd5fed04806b3b3ba6631ad7ed119b93b1f36eb10261a239127e238e4cf09ca2f4e7a SHA512 47a0b6c4c1b3d8ab18cf25725223c72683ed74084f0efd09cddbe293950839315f8fcadb16c2e5fa9a179745f20b08ce8652d4b972465eacc6a1792b4cfc296e
diff --git a/net-analyzer/netdata/netdata-1.22.1.ebuild b/net-analyzer/netdata/netdata-1.22.1.ebuild
new file mode 100644 (file)
index 0000000..2682b93
--- /dev/null
@@ -0,0 +1,140 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit autotools fcaps linux-info python-single-r1 systemd
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/netdata/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Linux real time system monitoring, done right!"
+HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
+
+LICENSE="GPL-3+ MIT BSD"
+SLOT="0"
+IUSE="caps +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc kinesis mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
+REQUIRED_USE="
+       mysql? ( python )
+       python? ( ${PYTHON_REQUIRED_USE} )
+       tor? ( python )"
+
+# most unconditional dependencies are for plugins.d/charts.d.plugin:
+RDEPEND="
+       acct-group/netdata
+       acct-user/netdata
+       app-misc/jq
+       >=app-shells/bash-4:0
+       || (
+               net-analyzer/openbsd-netcat
+               net-analyzer/netcat
+       )
+       net-misc/curl
+       net-misc/wget
+       sys-apps/util-linux
+       virtual/awk
+       caps? ( sys-libs/libcap )
+       cups? ( net-print/cups )
+       dbengine? (
+               app-arch/lz4
+               dev-libs/judy
+               dev-libs/openssl:=
+       )
+       dev-libs/libuv
+       compression? ( sys-libs/zlib )
+       ipmi? ( sys-libs/freeipmi )
+       jsonc? ( dev-libs/json-c )
+       kinesis? ( dev-libs/aws-sdk-cpp[kinesis] )
+       mongodb? ( dev-libs/mongo-c-driver )
+       nfacct? (
+               net-firewall/nfacct
+               net-libs/libmnl
+       )
+       nodejs? ( net-libs/nodejs )
+       prometheus? (
+               dev-libs/protobuf:=
+               app-arch/snappy
+       )
+       python? (
+               ${PYTHON_DEPS}
+               $(python_gen_cond_dep 'dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]')
+               mysql? (
+                       || (
+                               $(python_gen_cond_dep 'dev-python/mysqlclient[${PYTHON_MULTI_USEDEP}]')
+                               $(python_gen_cond_dep 'dev-python/mysql-python[${PYTHON_MULTI_USEDEP}]')
+                       )
+               )
+               postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_MULTI_USEDEP}]') )
+               tor? ( $(python_gen_cond_dep 'net-libs/stem[${PYTHON_MULTI_USEDEP}]') )
+       )
+       xen? (
+               app-emulation/xen-tools
+               dev-libs/yajl
+       )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+FILECAPS=(
+       'cap_dac_read_search,cap_sys_ptrace+ep' 'usr/libexec/netdata/plugins.d/apps.plugin'
+)
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+       linux-info_pkg_setup
+}
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --localstatedir="${EPREFIX}"/var \
+               --with-user=netdata \
+               --disable-cloud \ # https://github.com/netdata/netdata/issues/8961
+               $(use_enable jsonc) \
+               $(use_enable cups plugin-cups) \
+               $(use_enable dbengine) \
+               $(use_enable nfacct plugin-nfacct) \
+               $(use_enable ipmi plugin-freeipmi) \
+               $(use_enable kinesis backend-kinesis) \
+               $(use_enable mongodb backend-mongodb) \
+               $(use_enable prometheus backend-prometheus-remote-write) \
+               $(use_enable xen plugin-xenstat) \
+               $(use_enable cpu_flags_x86_sse2 x86-sse) \
+               $(use_with compression zlib)
+}
+
+src_install() {
+       default
+
+       rm -rf "${D}/var/cache" || die
+
+       keepdir /var/log/netdata
+       fowners -Rc netdata:netdata /var/log/netdata
+       keepdir /var/lib/netdata
+       keepdir /var/lib/netdata/registry
+       fowners -Rc netdata:netdata /var/lib/netdata
+
+       fowners -Rc root:netdata /usr/share/${PN}
+
+       newinitd system/netdata-openrc ${PN}
+       systemd_dounit system/netdata.service
+       insinto /etc/netdata
+       doins system/netdata.conf
+}
+
+pkg_postinst() {
+       fcaps_pkg_postinst
+
+       if use xen ; then
+               fcaps 'cap_dac_override' 'usr/libexec/netdata/plugins.d/xenstat.plugin'
+       fi
+}