sys-block/tgt: 1.0.79 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 2 Jul 2019 15:39:01 +0000 (10:39 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 2 Jul 2019 15:44:42 +0000 (10:44 -0500)
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
sys-block/tgt/Manifest
sys-block/tgt/tgt-1.0.79.ebuild [new file with mode: 0644]

index 3081a2478648df864a6f367d9817c0e7942c0b9a..a2a579dc92816f294291291c67482c644c9388de 100644 (file)
@@ -1,2 +1,3 @@
 DIST tgt-1.0.77.tar.gz 297550 BLAKE2B fdf5728b8b2d796a0b7d0845948d51161b1d2fa148c05e0c3940426a524246b3303b2e9aa6e748df54090ea3682a449edcf65c523ebd1e6d43b142e9339a605c SHA512 ad8d5519a6c1a46991d5b8c2f6d2990e2d064b81e82fb4700728153accf6aff05dab79c9d91ee55a9a6c344e7bd7451de4f26840162e08467a81a11d2d841bdd
 DIST tgt-1.0.78.tar.gz 297886 BLAKE2B c9edf8e5d0fe6a9788ff6bea4097f6cc0a8a905ffdc1943dcab538843445ede9142e1684121dad7f80677207607e20695bdad04fef622364c23df7cbeab1339a SHA512 dedafd490b6a042041fb9c8ed751747ec85f3bddab849fee301e0cf43b18aa92f5609657136700b867667fbff9ace62f4733c535cd425d8c71b072a7d7029430
+DIST tgt-1.0.79.tar.gz 297898 BLAKE2B d0f18dac863d6983a00eb9513bcbe17b5cbed76fad998af74b65311c1ace6f281bfb1bf639713e10124a520ad3916ef79ca0a81cef97b5ef678c25cfa9a71eaa SHA512 d71b0a08bd1cdc717e22c4dd0a229e84bd19e02e01037231ee80d9ab24848bc7274050e1ffe7d9a3d50149c892ed1e6ea382e54dacc341650f4534629116be07
diff --git a/sys-block/tgt/tgt-1.0.79.ebuild b/sys-block/tgt/tgt-1.0.79.ebuild
new file mode 100644 (file)
index 0000000..e6f4ccd
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic toolchain-funcs
+
+MY_TREE="b43dbc6"
+
+DESCRIPTION="Linux SCSI target framework (tgt)"
+HOMEPAGE="http://stgt.sourceforge.net"
+SRC_URI="https://github.com/fujita/tgt/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="fcoe fcp ibmvio infiniband rbd"
+
+CDEPEND="dev-perl/Config-General
+       dev-libs/libxslt
+       rbd? ( sys-cluster/ceph )
+       infiniband? (
+               sys-fabric/libibverbs:=
+               sys-fabric/librdmacm:=
+       )"
+DEPEND="${CDEPEND}
+       app-text/docbook-xsl-stylesheets"
+RDEPEND="${DEPEND}
+       dev-libs/libaio
+       sys-apps/sg3_utils"
+
+S=${WORKDIR}/fujita-tgt-${MY_TREE}
+
+pkg_setup() {
+       tc-export CC
+}
+
+src_prepare() {
+       sed -i -e 's:\($(CC)\) $^:\1 $(LDFLAGS) $^:' usr/Makefile || die
+       # make sure xml docs are generated before trying to install them
+       sed -i -e "s@install: @& all @g" doc/Makefile || die
+       eapply_user
+}
+
+src_compile() {
+       local myconf
+       use ibmvio && myconf="${myconf} IBMVIO=1"
+       use infiniband && myconf="${myconf} ISCSI_RDMA=1"
+       use fcp && myconf="${myconf} FCP=1"
+       use fcoe && myconf="${myconf} FCOE=1"
+       use rbd && myconf="${myconf} CEPH_RBD=1"
+
+       emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
+       emake -C doc
+}
+
+src_install() {
+       emake  install-programs install-scripts install-doc DESTDIR="${D}" docdir=/usr/share/doc/${PF}
+       newinitd "${FILESDIR}"/tgtd.initd tgtd
+       newconfd "${FILESDIR}"/tgtd.confd tgtd
+       dodir /etc/tgt
+       keepdir /etc/tgt
+}