dev-python/test_server: Enable py3.8, pypy3
authorMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 06:49:50 +0000 (07:49 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 07:22:19 +0000 (08:22 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/test_server/test_server-0.0.31.ebuild

index 722c8ee0daa03fd736087f9485167c01253e002b..aef01051c6d9d579a78ec863bed5ea732e5a95f6 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
 inherit distutils-r1
 
 DESCRIPTION="Server to test HTTP clients"
@@ -19,7 +19,6 @@ RDEPEND="
        >=dev-python/bottle-0.12.13[${PYTHON_USEDEP}]
        dev-python/six[${PYTHON_USEDEP}]
        dev-python/webtest[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 
 distutils_enable_tests pytest