version bump
authorAlin Năstac <mrness@gentoo.org>
Mon, 13 Mar 2006 06:08:48 +0000 (06:08 +0000)
committerAlin Năstac <mrness@gentoo.org>
Mon, 13 Mar 2006 06:08:48 +0000 (06:08 +0000)
Package-Manager: portage-2.0.54

net-dialup/pptpclient/ChangeLog
net-dialup/pptpclient/Manifest
net-dialup/pptpclient/files/digest-pptpclient-1.7.1 [new file with mode: 0644]
net-dialup/pptpclient/pptpclient-1.7.1.ebuild [new file with mode: 0644]

index c53211e7c4d6e39cba6288ac94c9f9539ba21454..047d486e8f28d3aeb796f1ed33c88186170515a2 100644 (file)
@@ -1,12 +1,14 @@
 # ChangeLog for net-dialup/pptpclient
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/ChangeLog,v 1.39 2006/03/13 05:53:43 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/ChangeLog,v 1.40 2006/03/13 06:08:48 mrness Exp $
+
+*pptpclient-1.7.1 (13 Mar 2006)
 
   13 Mar 2006; Alin Nastac <mrness@gentoo.org> -files/new-mppe/options.pptp,
   files/options.pptp, metadata.xml, -pptpclient-1.5.0-r1.ebuild,
   -pptpclient-1.5.0-r2.ebuild, -pptpclient-1.6.0.ebuild,
-  pptpclient-1.7.0.ebuild:
-  Remove old versions. Quote $WORKDIR and $FILESDIR.
+  pptpclient-1.7.0.ebuild, +pptpclient-1.7.1.ebuild:
+  Remove old versions. Quote $WORKDIR and $FILESDIR. Version bump.
 
   07 Feb 2006; Simon Stelling <blubb@gentoo.org> pptpclient-1.7.0.ebuild:
   stable on amd64
index 468917077992ab7cbfbe5ea2eecb4c7476c0c33f..7047158cc45c008726fcc7050f03833b5f48da9b 100644 (file)
@@ -1,17 +1,19 @@
 -----BEGIN PGP SIGNED MESSAGE-----
 Hash: SHA1
 
-MD5 bf52963832ffdaa326adda264b9a2895 ChangeLog 5874
+MD5 02aec27f5f91ceaef673bd6531b82d53 ChangeLog 5947
 MD5 437731fcd809ae5dd2adfc4bd5746c09 files/digest-pptpclient-1.7.0 129
+MD5 a2cab212edeaa33febd818a8b18586a4 files/digest-pptpclient-1.7.1 129
 MD5 eeee374ec64214d7f9c26a21ce8f4a36 files/options.pptp 340
 MD5 34862b5af00d851d068eb3e384093c3b files/pptp_fe.pl 8100
 MD5 bd60480b6ba90362342540fb9cbe7ebe files/xpptp_fe.pl 5620
 MD5 ee37a5b63158f3efa67cb4fc241cf868 metadata.xml 295
 MD5 84beb6d5e68db39a6731ddc15ea70847 pptpclient-1.7.0.ebuild 1143
+MD5 b9b0fb67f7793ea550b79e4e637731fb pptpclient-1.7.1.ebuild 1134
 -----BEGIN PGP SIGNATURE-----
 Version: GnuPG v1.4.2.1 (GNU/Linux)
 
-iD8DBQFEFQj7jG8pv1lIUX4RAmP9AJ9EjfdBXk8mhoekbaiUGDhu00PxywCg4m+V
-AltBqUn29AB7HQe8aLopDs4=
-=zgWt
+iD8DBQFEFQyCjG8pv1lIUX4RAofoAJ4grDHJFfrw6gaMO+tq45noz+rCPgCg78I6
+/JQzlvgEqD4Gpk/WWzSZ2PY=
+=pIum
 -----END PGP SIGNATURE-----
diff --git a/net-dialup/pptpclient/files/digest-pptpclient-1.7.1 b/net-dialup/pptpclient/files/digest-pptpclient-1.7.1
new file mode 100644 (file)
index 0000000..2a3ff0d
--- /dev/null
@@ -0,0 +1,2 @@
+MD5 b47735ba5d6d37dfdbccb85afc044ede pptp-1.7.1.tar.gz 229024
+MD5 a2fd08077b4c6ab1edd9e959901639cd pptp-command-20050401.gz 7662
diff --git a/net-dialup/pptpclient/pptpclient-1.7.1.ebuild b/net-dialup/pptpclient/pptpclient-1.7.1.ebuild
new file mode 100644 (file)
index 0000000..e30e46e
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/pptpclient-1.7.1.ebuild,v 1.1 2006/03/13 06:08:48 mrness Exp $
+
+MY_P=${P/client}
+MY_CMD=pptp-command-20050401
+
+DESCRIPTION="Linux client for PPTP"
+HOMEPAGE="http://pptpclient.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pptpclient/${MY_P}.tar.gz
+       mirror://gentoo/${MY_CMD}.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="tcltk"
+
+DEPEND=">=net-dialup/ppp-2.4.2
+       dev-lang/perl
+       tcltk? ( dev-perl/perl-tk )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+       emake OPTIMISE= DEBUG= CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+       dosbin pptp
+       dodoc AUTHORS ChangeLog DEVELOPERS NEWS README TODO USING
+       dodoc Documentation/*
+       dodoc Reference/*
+       dodir /etc/pptp.d
+
+       # The current version of pptp-linux doesn't include the
+       # RH-specific portions, so include them ourselves.
+       insinto /etc/ppp
+       doins options.pptp
+       newsbin "${WORKDIR}/${MY_CMD}" pptp-command
+       dosbin "${FILESDIR}/pptp_fe.pl"
+       use tcltk && dosbin "${FILESDIR}/xpptp_fe.pl"
+}