sys-apps/iproute2: Replace sed delimiters for possible gcc-9 CFLAGS
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 6 May 2019 08:12:26 +0000 (10:12 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 6 May 2019 08:12:26 +0000 (10:12 +0200)
Closes: https://bugs.gentoo.org/685168
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/iproute2/iproute2-4.14.1-r2.ebuild
sys-apps/iproute2/iproute2-4.17.0-r1.ebuild
sys-apps/iproute2/iproute2-4.19.0-r1.ebuild
sys-apps/iproute2/iproute2-4.20.0.ebuild
sys-apps/iproute2/iproute2-5.0.0.ebuild
sys-apps/iproute2/iproute2-9999.ebuild

index 74637c72653d51272cebbdb5ea162ef8f9f14d2e..3386bb728ed0a84122682b1b164ca4e5df6c4268 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -57,7 +57,7 @@ src_prepare() {
        sed -i \
                -e '/^CC :\?=/d' \
                -e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
-               -e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
+               -e "s|-O2|${CFLAGS} ${CPPFLAGS}|" \
                -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
                -e "/^WFLAGS/s:-Werror::" \
                -e "/^DBM_INCLUDE/s:=.*:=${T}:" \
index 29261b7f6ae1bc4befdb38d3d197238593be73d7..76f024a454dce0603bae574689c72fb0846d114c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -59,7 +59,7 @@ src_prepare() {
        sed -i \
                -e '/^CC :\?=/d' \
                -e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
-               -e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
+               -e "s|-O2|${CFLAGS} ${CPPFLAGS}|" \
                -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
                -e "/^DBM_INCLUDE/s:=.*:=${T}:" \
                Makefile || die
index fe34c36583b5ad1b3b49b74ccba73e349f86a7a0..bc6d40709395f87785b90fbd0904ea96a396e376 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -59,7 +59,7 @@ src_prepare() {
        sed -i \
                -e '/^CC :\?=/d' \
                -e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
-               -e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
+               -e "s|-O2|${CFLAGS} ${CPPFLAGS}|" \
                -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
                -e "/^DBM_INCLUDE/s:=.*:=${T}:" \
                Makefile || die
index aa41574d98b7a687b8881e2e4f8310461062090a..be77ce0b659bc7d9e962ef2c081cfd4723c76c72 100644 (file)
@@ -61,7 +61,7 @@ src_prepare() {
        sed -i \
                -e '/^CC :\?=/d' \
                -e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
-               -e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
+               -e "s|-O2|${CFLAGS} ${CPPFLAGS}|" \
                -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
                -e "/^DBM_INCLUDE/s:=.*:=${T}:" \
                Makefile || die
index 882d27c9d48daf5490a7808271251ca267ae9f87..f6ee223d9e1cc485fde3cc7ef94895977d2c9516 100644 (file)
@@ -61,7 +61,7 @@ src_prepare() {
        sed -i \
                -e '/^CC :\?=/d' \
                -e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
-               -e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
+               -e "s|-O2|${CFLAGS} ${CPPFLAGS}|" \
                -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
                -e "/^DBM_INCLUDE/s:=.*:=${T}:" \
                Makefile || die
index c6720ff8aed3b73e9cb6b01766ca48fc50a3daae..d5befeb1ccffabab15dce294087c09c03f8bc4ab 100644 (file)
@@ -61,7 +61,7 @@ src_prepare() {
        sed -i \
                -e '/^CC :\?=/d' \
                -e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
-               -e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
+               -e "s|-O2|${CFLAGS} ${CPPFLAGS}|" \
                -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
                -e "/^DBM_INCLUDE/s:=.*:=${T}:" \
                Makefile || die