sci-libs/sundials: 4.0.2 version bump
authorband-a-prend <torokhov-s-a@yandex.ru>
Sat, 22 Jun 2019 21:57:38 +0000 (00:57 +0300)
committerMatthias Maier <tamiko@gentoo.org>
Mon, 15 Jul 2019 21:33:27 +0000 (16:33 -0500)
Signed-off-by: Sergey Torokhov <torokhov_s_a@mail.ru>
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
sci-libs/sundials/Manifest
sci-libs/sundials/files/sundials-4.0.2-fix-license-install-path.patch [new file with mode: 0644]
sci-libs/sundials/sundials-4.0.2.ebuild [new file with mode: 0644]

index b2b2f1f462696cb6c0b6c215be15ea06ee27287b..45fd18330a5eeef28d0c136e097901c1f0ee3bed 100644 (file)
@@ -3,3 +3,4 @@ DIST sundials-3.0.0.tar.gz 12996039 BLAKE2B 0557190f6f7550bd4d7d3df10f727c6f235f
 DIST sundials-3.1.0.tar.gz 13033516 BLAKE2B 41294c1022ab09db6fbfa0d41c169d2ead3483693653a9c0cc26fdffec61918fed5e93241f64f9bfdc6ff22812fb846f3ea8deecd82c28d179dded85ec2c69ba SHA512 288427e00f58c512583cc14d81385e82b0fdeaa4e9adca588a108ad0752341b7be62c9fa2740924ec733e3e0d5794f305dc582fc72e244e675e5ea00ac0d08ca
 DIST sundials-3.1.2.tar.gz 18212893 BLAKE2B cee897f59920d6530553e4005b043fe615bf86ed6cc4ecb829afc25ea46c1a37cefd5a05584bd763af29689980d7bb03442ad22c4b83dd3af2406e786540652a SHA512 b65989998b440b2b5c5d000f4b86d8bcbf03215fcee4e348cd4b8ff935ea3471a3593ab8bd0e7d5f8ba519b5a1285cc93d41ec622d0b51592d7593c7579af082
 DIST sundials-3.2.1.tar.gz 14958699 BLAKE2B ecc4b454ec589e9177acc9375e1db370ad6281f8d29580d9558ad3146dbbaab52794013e9cb56ad83f7309dbd3084a1ccaf6972c6b1468cefcc86bf30d3a460c SHA512 1f3e4b12f368e4f50c38b970c012f1702e339319ee0a858661bdf83e5739bb5b8a36f98b82e2ef76d1ce8a473123046347ee1b44f3cb685509823864f0af1384
+DIST sundials-4.0.2.tar.gz 17183377 BLAKE2B e322a978186f41d84a936faa55962ef6794bf99d6c6a108bfa2bd5615f27f32f7ab6ca4989802fa052d3132b53dca3069b7e4ec9941f95efb92de7bf0792dd88 SHA512 6d0a6fc49c695e70593da71892f0906585dee9c94899bb6b8c9a56c85f345809565166a62544647fdac411d22e37276b9b1bb78ba9be46eaeb28dcd3f6162ef5
diff --git a/sci-libs/sundials/files/sundials-4.0.2-fix-license-install-path.patch b/sci-libs/sundials/files/sundials-4.0.2-fix-license-install-path.patch
new file mode 100644 (file)
index 0000000..3e2b65d
--- /dev/null
@@ -0,0 +1,11 @@
+diff -Nur old/CMakeLists.txt new/CMakeLists.txt
+--- old/CMakeLists.txt 2019-01-23 01:05:44.000000000 +0300
++++ new/CMakeLists.txt 2019-06-23 00:35:57.000000000 +0300
+@@ -1214,6 +1214,6 @@
+   )
+ INSTALL(
+   FILES ${PROJECT_SOURCE_DIR}/NOTICE
+-  DESTINATION include/sundials
++  DESTINATION share/doc/sundials-4.0.2)
+   )
diff --git a/sci-libs/sundials/sundials-4.0.2.ebuild b/sci-libs/sundials/sundials-4.0.2.ebuild
new file mode 100644 (file)
index 0000000..649b2f4
--- /dev/null
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD=90
+
+inherit cmake-utils eapi7-ver toolchain-funcs fortran-2
+
+DESCRIPTION="Suite of nonlinear solvers"
+HOMEPAGE="https://computation.llnl.gov/projects/sundials"
+SRC_URI="https://computation.llnl.gov/projects/sundials/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cxx doc examples fortran hypre lapack mpi openmp sparse static-libs superlumt threads"
+REQUIRED_USE="hypre? ( mpi )"
+
+RDEPEND="
+       lapack? ( virtual/lapack )
+       mpi? ( virtual/mpi sci-libs/hypre:= )
+       sparse? ( sci-libs/klu:= )
+       superlumt? ( sci-libs/superlu_mt:= )
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-license-install-path.patch )
+
+pkg_setup() {
+       if [[ ${MERGE_TYPE} != binary ]] && use openmp && [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+               ewarn "OpenMP is not available in your current selected gcc"
+               die "need openmp capable gcc"
+       fi
+}
+
+src_configure() {
+       mycmakeargs+=(
+               -DBUILD_SHARED_LIBS=ON
+               -DBUILD_STATIC_LIBS="$(usex static-libs)"
+               -DCXX_ENABLE="$(usex cxx)"
+               -DFCMIX_ENABLE="$(usex fortran)"
+               -DF90_ENABLE="$(usex fortran)"
+               -DHYPRE_ENABLE="$(usex hypre)"
+               -DHYPRE_INCLUDE_DIR="${EPREFIX}/usr/include/hypre"
+               -DKLU_ENABLE="$(usex sparse)"
+               -DKLU_LIBRARY="${EPREFIX}/usr/$(get_libdir)/libklu.so"
+               -DLAPACK_ENABLE="$(usex lapack)"
+               -DMPI_ENABLE="$(usex mpi)"
+               -DOPENMP_ENABLE="$(usex openmp)"
+               -DPTHREAD_ENABLE="$(usex threads)"
+               -DSUPERLUMT_ENABLE="$(usex superlumt)"
+               -DSUPERLUMT_INCLUDE_DIR="${EPREFIX}/usr/include/superlu_mt"
+               -DSUPERLUMT_LIBRARY="superlu_mt"
+               -DEXAMPLES_ENABLE="$(usex examples)"
+               -DEXAMPLES_INSTALL=ON
+               -DEXAMPLES_INSTALL_PATH="/usr/share/doc/${PF}/examples"
+               -DUSE_GENERIC_MATH=ON
+       )
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+       use doc && dodoc doc/*/*.pdf
+       cd src
+       for r in */README; do
+               newdoc ${r} README-${r%/*}
+       done
+}