net-libs/webkit-gtk: fix build with -j1
authorAlexandre Rostovtsev <tetromino@gentoo.org>
Tue, 25 Aug 2015 00:40:38 +0000 (20:40 -0400)
committerAlexandre Rostovtsev <tetromino@gentoo.org>
Tue, 25 Aug 2015 00:45:11 +0000 (20:45 -0400)
Reported-by: dolphinling
Gentoo-Bug: 556680
Upstream-Bug-url: https://bugs.webkit.org/show_bug.cgi?id=148379
Package-Manager: portage-2.2.20.1

net-libs/webkit-gtk/files/webkit-gtk-2.8.5-webkit2gtkinjectedbundle-j1.patch [new file with mode: 0644]
net-libs/webkit-gtk/webkit-gtk-2.8.5.ebuild

diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.8.5-webkit2gtkinjectedbundle-j1.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.8.5-webkit2gtkinjectedbundle-j1.patch
new file mode 100644 (file)
index 0000000..79b57ae
--- /dev/null
@@ -0,0 +1,22 @@
+2015-08-24  Alexandre Rostovtsev  <tetromino@gentoo.org>
+
+        webkit2gtkinjectedbundle requires forwarding headers
+        https://bugs.webkit.org/show_bug.cgi?id=148379
+
+        Fixes GTK build with -j1
+
+        * PlatformGTK.cmake:
+Index: Source/WebKit2/PlatformGTK.cmake
+===================================================================
+--- Source/WebKit2/PlatformGTK.cmake   (revision 188859)
++++ Source/WebKit2/PlatformGTK.cmake   (working copy)
+@@ -860,7 +860,7 @@ include_directories(
+ )
+ add_library(webkit2gtkinjectedbundle MODULE "${WEBKIT2_DIR}/WebProcess/gtk/WebGtkInjectedBundleMain.cpp")
+-add_dependencies(webkit2gtkinjectedbundle GObjectDOMBindings)
++add_dependencies(webkit2gtkinjectedbundle GObjectDOMBindings WebKit2-forwarding-headers)
+ add_webkit2_prefix_header(webkit2gtkinjectedbundle)
+ # Add ${CMAKE_LIBRARY_OUTPUT_DIRECTORY} to LD_LIBRARY_PATH
index b0a62133f71385efff7af6287de82ac5e742d78d..18ae36ab6a0b51bc2fdab200ff8630c52ae39e38 100644 (file)
@@ -141,6 +141,9 @@ src_prepare() {
        # https://bugs.webkit.org/show_bug.cgi?id=129542
        epatch "${FILESDIR}"/${PN}-2.8.1-ia64-malloc.patch
 
+       # https://bugs.webkit.org/show_bug.cgi?id=148379
+       epatch "${FILESDIR}"/${PN}-2.8.5-webkit2gtkinjectedbundle-j1.patch
+
        gnome2_src_prepare
 }